SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

Enable special characters, "xx"n

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

Enable special characters, "xx"n

Hi,

We have several user written transformation that we are using in our SAS DI studio. We have upgraded from 9.2 to 9.4 version.

Somehow our UW transformations don't work anymore. When I try to add a UW, DIS adding "xx"n to all variables. I have check all over if we have any parameters that are sett to enable special characters on column and variables without luck.

Do anyone have experiences this before?

Example:

        label = 'Valid From Datetime';

         attrib "VALID_TO_DTTM"n length = 8

Br

Linus


Accepted Solutions
Solution
‎04-22-2014 08:08 AM
New Contributor
Posts: 3

Re: Enable special characters, "xx"n

Hi Patrick,

Your answer lead me on the right path here. All the standard transformations also got there variables with quotation marks.

I realized that after our upgrade to 9.4 my settings have been restored to default, and under option the setting "Enable case-sensitive DBMS object" was enabled. After deselect that option it works fine again Smiley Happy

Thanks for the help!

Br

Linus

View solution in original post


All Replies
PROC Star
Posts: 1,167

Re: Enable special characters, "xx"n

The only significance of the "xx"n notation is that it will work for variables that don't meet SAS naming conventions. Your SAS code should still work. I tried your two line example, and it worked fine.

What kind of diagnostics are you getting that are causing your transformations to not work?

Tom

New Contributor
Posts: 3

Re: Enable special characters, "xx"n

Hi TomKari,

It works fine when we are using standard transformations but when we are using a user written we get trouble. Somewhere in the UW's macro it puts another par of "".

But what we really trying to find out is how to turn off that SAS DIS adding ""n on out variables. 

Respected Advisor
Posts: 4,173

Re: Enable special characters, "xx"n

Are the standard transformations also quoting the variables? If not then this is very likely a DI unrelated issue and you need to de-bug the user written macro and get to the point where it adds these quotes. May be the logic is based on some options like "validvarname" which changed in your new environment and now the macro is doing something wrong.

Under SAS(R) Data Integration Studio 4.5: User's Guide there is a note stating:

Avoid Double Quotation Marks in DBMS Table and Column Names

SAS Data Integration Studio cannot successfully generate code for a job that includes a DBMS table in which the double quotation mark is used in the table name or the column names.

I don't believe this applies to your case as you're using user written code.

I believe DI Studio would only generate code for SAS name literals if specifically selected as Table Metadata Property

SAS(R) Data Integration Studio 4.4: User's Guide

Select Enable special characters within DBMS object names to support special characters in table and column names.

But still: Why should this change anything for user written code unless this user written code is actually querying table metadata and then generating code accordingly.

Solution
‎04-22-2014 08:08 AM
New Contributor
Posts: 3

Re: Enable special characters, "xx"n

Hi Patrick,

Your answer lead me on the right path here. All the standard transformations also got there variables with quotation marks.

I realized that after our upgrade to 9.4 my settings have been restored to default, and under option the setting "Enable case-sensitive DBMS object" was enabled. After deselect that option it works fine again Smiley Happy

Thanks for the help!

Br

Linus

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 1344 views
  • 3 likes
  • 3 in conversation