SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

ERROR: LIBNAME domain schemaname not found in SPD Name Server.

Reply
Occasional Contributor
Posts: 11

ERROR: LIBNAME domain schemaname not found in SPD Name Server.

Hello everybody,

 

I am trying to verify if I had created my SAS Scalable Performance Data Server Library.

 

So far I have created my library, with server details and connection details as of the default tables' details. After that I tried to run the libname statement given and was prompted with error schemaname not found in SPD Name Server.

 

Default tables can be located at Products>SAS Quality Analytic Suite> SAS Asset Performance Analytics>Data Mart SPDS Tables.

 

Libname statement: LIBNAME test SASSPDS  IP=YES  LIBGEN=YES  Serv='1234'  HOST='hostname'  SCHEMA="schemaname"  AUTHDOMAIN="authdomainname" ALTPATH= YES;

                                  

If anybody has encountered this issue, please advice on the steps that is able to solve this issue.

Super User
Posts: 5,853

Re: ERROR: LIBNAME domain schemaname not found in SPD Name Server.

I haven't used this suite with SPDS, but strictly speaking of the schema:
- check that the name exists and have the exact spelling in the libname.parm file
- check the data server log to see that the domain is valid
- check the nameserver log to see that the data server is registered properly with it's libname domains
Data never sleeps
Ask a Question
Discussion stats
  • 1 reply
  • 126 views
  • 0 likes
  • 2 in conversation