SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

Disabling prewritten code

Posts: 38

Disabling prewritten code

Hi all,

since DI Studio 4.21 certain transformations generate lots of code before the actual magic happens. The "User Written Code" transformation for example does this:

%let _OUTPUT_col_count = 274;
%let _OUTPUT_col0_name = ORIG_ASW_SPREAD;
%let _OUTPUT_col0_table = work.W5R1G8EW;
%let _OUTPUT_col0_length = 8;
%let _OUTPUT_col0_type = ;
%let _OUTPUT_col0_format = 18.6;
%let _OUTPUT_col0_informat = 18.6;
%let _OUTPUT_col0_label = %nrquote(ORIG_ASW_SPREAD);
%let _OUTPUT_col0_input0 = ORIG_ASW_SPREAD;
%let _OUTPUT_col0_exp = ;
%let _OUTPUT_col0_input = ORIG_ASW_SPREAD;
%let _OUTPUT_col0_input_count = 1;

Multiply this for the rest of the 200 columns and the code overhead is pretty huge.

In the former version there was (besides smaller things) only the output_ as well as the &syslast defined.

Is there a way to disable the macro variables for each and every column?

Super Contributor
Posts: 356

Re: Disabling prewritten code

Posted in reply to thomash123
You can turn off,

on the code tab of your user written code, above the code segment there is a drop down selection, one of these options turns of the automatically generated code.

I think that is what you are after.

Posts: 38

Re: Disabling prewritten code

Posted in reply to twocanbazza
Hi twocanbazza,

thanks for your reply. I tried this, but then it does not even generate the _output or syslast variables.

This was the case in DI Studio 3.4 and none of my jobs has this in the manually written code.
SAS Employee
Posts: 41

Re: Disabling prewritten code

Posted in reply to thomash123
I have confirmed that we don't have any option that turns off some of these variables but not others. As one of the other users posted, you can choose to go "All User Written" in which case we won't generate any code, it is entirely up to the user to generate whatever code they want. You can go to "User written body" which causes DI Studio to generate the macros (all of the macros, not some of them) but not the body of the transform. Or you can go to all generated. We put a requirement in to consider additional options for the future.
Ask a Question
Discussion stats
  • 3 replies
  • 3 in conversation