SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

Disable SAS DI 4.9 automatic mapping

Reply
Occasional Contributor
Posts: 13

Disable SAS DI 4.9 automatic mapping

Am trying to disable the automatic mappings in SAS DI 4.9.

Noticed that even after removing mapped columns from the Extract transformation and save it, it still appears after I open the saved job. Have removed all the checks for the 'Automatic Settings' on the 'Job Editor' tab under the Tools menu option.

Thanks.

 

Super User
Posts: 5,441

Re: Disable SAS DI 4.9 automatic mapping

That setting affects new jobs.

Already existing jobs have already inherited that setting.

You can on the job level change this, by just right click on the canvas, and un-select "Automatically Map Columns". under "Automation Settings".

Data never sleeps
Super User
Posts: 5,441

Re: Disable SAS DI 4.9 automatic mapping

Moving the thread to the forum for DI Studio issues - Data Management.

Data never sleeps
Occasional Contributor
Posts: 13

Re: Disable SAS DI 4.9 automatic mapping

Thanks, it works. Had created the job earlier with the options for the automatic mapping off but somehow the job did not inherit it.

Ask a Question
Discussion stats
  • 3 replies
  • 322 views
  • 0 likes
  • 2 in conversation