SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

DI Studio 4.21 install on Windows 7 x62

Accepted Solution Solved
Reply
Contributor
Posts: 38
Accepted Solution

DI Studio 4.21 install on Windows 7 x62

Our DIS on Windows XP is working fine, Win XP x32.

No changes on the Server side, it is on Win 2008R2 x64.

So we start installation and set of DIS 4.21 (TS2M2) on the Windows 7 x64. No problem in the installation process.

But when we try to connect it sends back an error message:

-------------------------------------------------------------------------------------

Socket operation on nonsocket: no further information

Unable to establish loopback connection

-------------------------------------------------------------------------------------

The hosts file is fine and I am running as local administrator.

SAS Support is trying to help me  for last 25 days with no success!!!

Anyone who has encountered this and resolved it.

Much appreciated,

Misbah.


Accepted Solutions
Solution
‎07-09-2012 11:12 AM
Contributor
Posts: 38

Re: DI Studio 4.21 install on Windows 7 x62

I worked on a test machine. Installed and invoked the application. Worked perfectly.

Then I did a compare with my machine.

STRANGELY enough!!! The ISA Client (ISACLIENT-KB929556-ENU.EXE) on my Win-7 was the culprit. After removing the program I was able to connect to the server.

EXPLANATION: I had the ISA Client on the XP and it did not affect the SAS communication, somehow. And I installed on the Win-7 knowing that it does not block SAS communication.  So, when troubleshooting on the Win-7 I disabled the service of ISA-CLIENT and still it keeps blocking. I am not sure why would it do that but at least I got it to working now.

May be you folks can explain as to why a disabled service will still come in the way.

Thanks for all those who participated and help me out.

Misbah.

View solution in original post


All Replies
Respected Advisor
Posts: 4,173

Re: DI Studio 4.21 install on Windows 7 x62

I was just curious what "Socket operation on nonsocket: no further information" might mean.

While "Googling" I found that one of the tests to get to the root cause is "Temporarily disable your firewall, antivirus and other Internet security  programs".

Also for the second message "Unable to establish loopback connection" I found several things on the Internet which point to a "firewall blocking issue".

As you're installing new software it might simply get blocked.

Contributor
Posts: 38

Re: DI Studio 4.21 install on Windows 7 x62

They asked me to stop all Anti-virus services and firewall while installing. Also disabled to do a test, that did not work.

I am using the same profile to connect through my XP machine and it is fine, it works under the firewall!

Sure it seems the communication is blocked, but where? Support does not say anything!!!

Contributor
Posts: 69

Re: DI Studio 4.21 install on Windows 7 x62

I'm curious if the problem is specific to DI Studio and your specific version.  Knowing the scope of the problem might point towards a solution.


Do you have any other SAS products installed on the Win7x64 platform that can successfully connect to the server... such as Base SAS?

It would be a pain, but do you have a different version of DI Studio that runs under Win7x64 you could install and test?

Contributor
Posts: 38

Re: DI Studio 4.21 install on Windows 7 x62

Posted in reply to bentleyj1

We just moved our PC (from Win-XP x32) to Win-7 x64. We already have DIS installed and working on Win-XP machine. According to support site the TS2M2 version is compatible and the support thread does not have any satisfactory answer yet !!!

No, we do not have any other product installed on the Win 7.

Contributor
Posts: 69

Re: DI Studio 4.21 install on Windows 7 x62

You're running the 9.2 Metadata Server on the server right?  I don't know that DI 4.2 can connect to a 9.1 server.

If your DI studio installation media runs under Win7 both 32-bit and 64-bit then under the 64-bit OS it must be running in 32-bit emulation mode. 

I'm just throwing out troubleshooting ideas here, but you might want to use Google to check on communication/connectivity problems with the 32-bit emulation mode, maybe something like 'Win7 64-bit 32-bit emulation communication issues'.

I see that there is a hot fix for DI Studio 4.21 for Win x64.  Lots of issues addressed.  Have you installed it?  Scrolling thru I don't see anything related to your problem but it would still be good to install it. I didn't check hot fixes for the Metadata Server but if there are any you haven't installed you probably should.

ftp://ftp.sas.com/techsup/download/hotfix/HF2/B51_wx6.html#B51005

Also I think most if not all the performance increase due to the 64-bit OS is being lost for DI Studio because the OS is slowing down to 32-bit to run it.  If this box is not running any software that _requires_ 64-bit then you might want to switch to the 32-bit version of Win7.

Contributor
Posts: 38

Re: DI Studio 4.21 install on Windows 7 x62

Posted in reply to bentleyj1

SAS Support suggested TS2M2. No patches were recommended or installed on top of that.

Since the software sits under 'Program Files' I will assume it is a x64 software.

Contributor
Posts: 69

Re: DI Studio 4.21 install on Windows 7 x62

Checking Help, About SAS might tell if you're running 64-bit SAS.  If it doesn't say so explicitly, then check the installation CDs if you have them or ask your in-house SAS representative.  This is an important piece of information to be sure about because it is basic to troubleshooting.

Super Contributor
Posts: 349

Re: DI Studio 4.21 install on Windows 7 x62

Posted in reply to bentleyj1

Hi,

I guess ports might be blocked by your network team to that particular PC or just try to telnet to the metadata server port 8561 from you client machine and try..

or check the JRE version (because xp and window 7 uses different JRE versions)

Thanks,

Shiva

Contributor
Posts: 38

Re: DI Studio 4.21 install on Windows 7 x62

We checked and ports are open.

Also, the certified version of JRE was installed.

Thanks,

Solution
‎07-09-2012 11:12 AM
Contributor
Posts: 38

Re: DI Studio 4.21 install on Windows 7 x62

I worked on a test machine. Installed and invoked the application. Worked perfectly.

Then I did a compare with my machine.

STRANGELY enough!!! The ISA Client (ISACLIENT-KB929556-ENU.EXE) on my Win-7 was the culprit. After removing the program I was able to connect to the server.

EXPLANATION: I had the ISA Client on the XP and it did not affect the SAS communication, somehow. And I installed on the Win-7 knowing that it does not block SAS communication.  So, when troubleshooting on the Win-7 I disabled the service of ISA-CLIENT and still it keeps blocking. I am not sure why would it do that but at least I got it to working now.

May be you folks can explain as to why a disabled service will still come in the way.

Thanks for all those who participated and help me out.

Misbah.

Contributor
Posts: 69

Re: DI Studio 4.21 install on Windows 7 x62

Glad to hear that you figured it out.  Firewall issue, eh?  More research is probably needed because you might not want to disable your firewall client.  I know almost nothing about firewalls, but maybe figure out how to tell it that your SAS server is trusted.  But then again, if you're on an intranet maybe you don't need a desktop firewall.  I googled 'ISA Client' and got lots of hits.  Good luck.

You might want to mark this question as 'answered'.

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 11 replies
  • 762 views
  • 0 likes
  • 4 in conversation