We’re smarter together. Learn from this collection of community knowledge and add your expertise.

Data Partition Node SAS EM

by Occasional Contributor Sasman1441 on ‎10-19-2013 11:17 PM - edited on ‎10-06-2015 03:07 PM by Community Manager (474 Views)

I cant get the data partition node to work (i.e. partition my data)

 

It works for one of my data set but not for the others... for those that dont work it gives an error that says "Invalid segmentation level"

 

What does this mean?  Is something wrong with my dataset?

 

 

I get the error with the dataset attached called "small"!

Small is a reduced size version of the original dataset!

Comments
by Community Manager
on ‎10-21-2013 09:39 AM

Hi Sasman1441,

Thank you for posting your question. You may want to recreate this as a "discussion" (see "Start a discussion" link under "Actions" in the right column of the data mining community landing page). That way, replies to your question will surface at the top of the "Recent Content" thread. This is currently set up as an "article" where comments/replies aren't as visible.

Best,

Anna

by SAS Employee JasonXin
on ‎10-30-2013 12:25 PM

Sasman1441,

I tested your data with EM 12.3. The partition runs fine.

"

User:                sasdemo

Date:                October 30, 2013

Time:                12:17:41

*------------------------------------------------------------*

* Training Output

*------------------------------------------------------------*

"

Variable Summary

            Measurement    Frequency

Role           Level         Count

INPUT        INTERVAL          45

INPUT        NOMINAL            4

REJECTED     NOMINAL            1

Partition Summary

                                     Number of

Type             Data Set          Observations

DATA        EMWS1.Ids_DATA             51118

TRAIN       EMWS1.Part_TRAIN           20447

VALIDATE    EMWS1.Part_VALIDATE        15335

TEST        EMWS1.Part_TEST            15336

"

I did not find any message from SAS support KB or google.com. I suspect you may be using one old EM version 5.2 or...? Let me know.

Jason Xin

Contributors
Your turn
Sign In!

Want to write an article? Sign in with your profile.


Looking for the Ask the Expert series? Find it in its new home: communities.sas.com/askexpert.