Learning SAS? Welcome to the exclusive online community for all SAS learners.

obdc not working wondering if the edition is missing a component

Accepted Solution Solved
Reply
New Contributor
Posts: 2
Accepted Solution

obdc not working wondering if the edition is missing a component

Hi I have been using SAS U successfully for some time. As I have gotten more advanced I have been using more and more data. I have gotten to a point where I need to connect to a data base. I use mysql and set up a mysql odbc. When I run a Proc setinit noalias; Run; I do get

---SAS/ACCESS Interface to ODBC.

The library I am using uses the path /folders/myfolders/. I am trying to run a few different comands into the program to connect, the most recent being

libname retro odbc dsn='mysql' user='root';

Each time I get the same error

1 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK;

ERROR: Could not load /opt/sasinside/SASHome/SASFoundation/9.4/sasexe/sasodb (112 images loaded)

ERROR: libodbc.so: cannot open shared object file: No such file or directory

I have never gotten an error on this line before, I am wondering what the problem is. I did a google on the error and went to the facebook page which did not help.

Is this a limitation on SAS U or a problem with my set up. Please help I have having this problem all weekend.


Accepted Solutions
Solution
‎08-03-2015 09:09 AM
Super User
Super User
Posts: 7,395

Re: obdc not working wondering if the edition is missing a component

Strange that when you google that you get a facebook page, I just get a list of questions like this, and some other techincal stuff.  Try this thread:

View solution in original post


All Replies
Solution
‎08-03-2015 09:09 AM
Super User
Super User
Posts: 7,395

Re: obdc not working wondering if the edition is missing a component

Strange that when you google that you get a facebook page, I just get a list of questions like this, and some other techincal stuff.  Try this thread:

New Contributor
Posts: 2

Re: obdc not working wondering if the edition is missing a component

I thought it was weird also. Thanks so much for the quick reply and that link. It answered my question.

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 518 views
  • 1 like
  • 2 in conversation