Learning SAS? Welcome to the exclusive online community for all SAS learners.

(Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Accepted Solution Solved
Reply
SAS Employee
Posts: 1
Accepted Solution

(Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

[ Edited ]

Based on preliminary testing, it appears that the myfolders Shared Folder used by SAS University Edition cannot be seen by Oracle VirtualBox version 5.2.8.

 

If you are experiencing this issue, please revert back to version 5.2.6 of Virtual Box available here: . https://www.virtualbox.org/wiki/Download_Old_Builds_5_2 This will allow your Shared Folder to be seen.

 

** FIXED LINK TO REMOVE TRAILING SPACE **


Accepted Solutions
Solution
‎04-20-2018 03:48 PM
SAS Employee
Posts: 168

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0

new release of SAS University Edition was pushed today which addresses the issues introduced by the Virtual Box shared folders changes.  You should now be able to use whatever release of Virtual Box you wish & your shared folders should work fine.  If not, please open a new post or open a tech support track.  Sorry for the problems!

View solution in original post


All Replies
New User
Posts: 1

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0

Yes.  I solved this issue by using 5.2.4 or 5.2.8 for installation. But it shows "A shared folder named "myfolders" was not found on the virtual machine. See the FAQ for details" when I run http://localhost:10080.  Even I can open a SAS session successfully, I can't import data file into the session.

 

Regular Learner
Posts: 1

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0

Not to complaining since it's not the fault of SAS, but running the cycle of uninstall-install-import OVA to revert to VB 5.2.4, then running the cycle once more when the bug is fixed is a huge waste of time. Reverting wouldn't be as burdensome if VB tolerated simultaneous installation of multiple versions, but I understand this is another can of worms. Looks like VB has had <24 h to take the ticket seriously (after first rejecting it), and I hope VB can offer a patch or workaround in short order.

SAS Employee
Posts: 3

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0

I just ran into this issue myself, and found an easy solution that doesnt require back leveling VIrtualBox...

 

Make sure that your VM isnt running.

Open the command prompt,

 

> cd "C:\Program Files\Oracle\VirtualBox"

> VBoxManage.exe guestproperty get "SAS University Edition" "/VirtualBox/GuestAdd/SharedFolders/MountPrefix"
No value set! 

> VBoxManage.exe guestproperty set "SAS University Edition" "/VirtualBox/GuestAdd/SharedFolders/MountPrefix" "/"

> VBoxManage.exe guestproperty get "SAS University Edition" "/VirtualBox/GuestAdd/SharedFolders/MountPrefix"
Value: /

 

When your start your VM, the shared folder will exist and you should be all set!

 

If and when this is ever fixed officially, via SAS or VirtualBox, you can simply call the "set" command without a value to reset it back to the default

 

> VBoxManage.exe guestproperty set "SAS University Edition" "/VirtualBox/GuestAdd/SharedFolders/MountPrefix"

> VBoxManage.exe guestproperty get "SAS University Edition" "/VirtualBox/GuestAdd/SharedFolders/MountPrefix"
No value set!

Learner
Posts: 1

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to BMWilliams
Unfortunately the solution of BMWilliams didn't work at my pc :-/
New Contributor
Posts: 2

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

[ Edited ]
Posted in reply to BMWilliams

Your solution worked on OSX 10.13.3
Thanks.
Did not want to revert to previous version

New Contributor
Posts: 2

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch


@zackzoxwrote:

Your solution worked on OSX 10.13.3
Thanks.
Did not want to revert to previous version

 


Hi zackzox do you mind sharing the commands you used for OSX? 

Thanks

New Contributor
Posts: 2

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to daviddq12
Open terminal
use   VBoxManage  instead of VBoxManage.exe

New Contributor
Posts: 2

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0
So I have also run into this problem on Linux (Fedora 25 originally, now Fedora 27). Rolling back to an old version of Virtual Box (5.1.34) fixed the problem in Fedora 25, then when I upgraded to the latest Fedora release the Virtual Box kernel failed to compile. Thusly, I had to upgrade Virtual Box. I went with 5.2.8, hoping that Oracle would have released a bugfix by now. At which point I of course re-encountered this problem (which apparently Oracle still haven't addressed). So I rolled back to 5.2.6, which resolved the not mounting of "myfolders", however, a new problem occurs now. When I launch SAS UE in Firefox 59.0.1 it signs in but gets hung-up at initializing and won't successfully launch. However, for anyone else with this problem there is good news, SAS UE will initialize using Chromium 63.0.3239.108 (Developer Build). I realize this may be beyond the scope of this thread, but I didn't want to start an extra unnecessary thread. So, on the off-chance that I am not the only person running Fedora 27 and SAS UE that has encountered this problem I wanted to post my solution here since this is where my searching brought me. In summary, I am using Virtual Box 5.2.6 and Chromium to get around this problem for now.
SAS Employee
Posts: 3

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Hey zwintrob,

In theory, the solution that I posted above should also work on Linux.  Any chance you tried it before rolling back?

 

Thanks!

New Contributor
Posts: 2

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

[ Edited ]
Posted in reply to BMWilliams

Hi BMWilliams,
No, much to my shame, I have to admit I did not attempt your solution first. I had a very pressing assignment deadline and desperately needed a "quick" fix and didn't feel like digging though the program code (even considered reverting to an old version of my distro at some point before I gave Chromium a try). Anyway, I will definitely give your solution a try (perhaps this weekend if I get the chance) and report my findings. Just looking at it I agree that it should work. Thanks!

New Contributor
Posts: 3

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0

Thanks Chris!


I had a couple of issues until I went back to VB 5.2.6.

Eg 5.2.8 wouldn't successfully import the ovi file that I had downloaded a couple of times, so I gave up for a few days and then tried again. 

After I got 5.2.6 , I think it still had an old ovi file still loaded(one I tried months ago) and that gave me problems. I then correctly removed it and then it successfully loaded the latest ovi file and now recognised the myfiles folder (once I defined it again).

 

Looks good now.

...Leo

New User
Posts: 1

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Thanks, all. Just to confirm, reverting back to VB 5.2.6 also worked on my Mac, OS X 10.13.3.

 

New User
Posts: 1

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to markgewhite

i'm new to sas university edition.  do not see a newly defined shared folder from my local machine (e.g., C:\sasfiles\study2).

.

The demo video I saw is using VM Player to define the shared folder.  I tried to follow the same steps using Virtual Box 5.2.6, but so far still not seeing the shared folder from within sas studio, even after reloading the browser.  I see myfolders and everything in it without any issues.  Since this is the case, assume I did not create the folder shortcut properly.

 

Anyone else run into this problem using 5.2.6?  

Thanks!

New User
Posts: 1

Re: (Virtual Box 5.2.8) SAS University Edition myfolders is not found after launch

Posted in reply to chrislockard0

Thank you so much!!!!

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 19 replies
  • 2339 views
  • 21 likes
  • 14 in conversation