Learning SAS? Welcome to the exclusive online community for all SAS learners.

Shared folder not found on a new installation

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 7
Accepted Solution

Shared folder not found on a new installation

Hello Community...

 

I just installed the SAS University Edition on a Virtualbox VM. When I start it up at http://localhost:10080, I get the message that the shared folder "myfolders" is not found.  I have confirmed that the folder exists by creating a program file and saving it then going back to my Windows host to confirm that it is there.  It is. 

 

I then read that sometimes when checking for an upgrade the system cannot find the myfolders folder but when I try to upgrade it tells me that there is something wrong with my internet connection. There is nothing wrong.  I am connected to the internet just fine.

 

Any suggestions?


Accepted Solutions
Solution
‎01-29-2018 08:36 PM
Super User
Posts: 24,028

Re: Shared folder not found on a new installation

Posted in reply to d0325mgray

It's supposed to be myfolderS -> you're missing the 's'?

 

If the issue persists, please post screenshots of your set up in the VM and the error messages in SAS from the libname statement.

 

And if you can create a libname I wouldn't worry too much, I would restart my VM and my browser and you shouldn't receive that warning anymore. 

 

libname test '/folders/myfolders/';

d0325mgray wrote:
It is "myfolder"...

 

View solution in original post


All Replies
Super User
Posts: 10,626

Re: Shared folder not found on a new installation

Posted in reply to d0325mgray

Maybe you have a typo somewhere, confusing "myfolder" with "myfolders". AFAIK, the whole path as suggested is "/folders/myfolder".

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Occasional Contributor
Posts: 7

Re: Shared folder not found on a new installation

Posted in reply to KurtBremser
It is "myfolder"...
Super User
Posts: 10,626

Re: Shared folder not found on a new installation

Posted in reply to d0325mgray

So basically, you get a message when starting up, but then everything works fine (as you could save a program)?

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Occasional Contributor
Posts: 7

Re: Shared folder not found on a new installation

Posted in reply to KurtBremser
Yes. Exactly.

Like I said, I expect the problem is that I cannot update the server
running on the virtual machine
Super User
Posts: 10,626

Re: Shared folder not found on a new installation

Posted in reply to d0325mgray

Then I'd try to manually download a new copy of the ova file and do a complete installation from scratch (instead of the more-or-less automated update).

Data in the shared folder (which resides on the host operating system) is not affected by a reinstall AFAIK, but you can make a copy of that anyway before installing.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Solution
‎01-29-2018 08:36 PM
Super User
Posts: 24,028

Re: Shared folder not found on a new installation

Posted in reply to d0325mgray

It's supposed to be myfolderS -> you're missing the 's'?

 

If the issue persists, please post screenshots of your set up in the VM and the error messages in SAS from the libname statement.

 

And if you can create a libname I wouldn't worry too much, I would restart my VM and my browser and you shouldn't receive that warning anymore. 

 

libname test '/folders/myfolders/';

d0325mgray wrote:
It is "myfolder"...

 

Occasional Contributor
Posts: 7

Re: Shared folder not found on a new installation

There is some confusion.  One reply said myfolder and another said myfolders.  I checked everything again and found that I had the path on the PC set correctly and specified correctly in the VM setup but left the 's' off the share name.  All is okay now

Super User
Posts: 24,028

Re: Shared folder not found on a new installation

Posted in reply to d0325mgray

Well, this is a user forum so you get what you pay for Smiley Happy

 

The documentation and instructions all say myfolders. 

 


d0325mgray wrote:

There is some confusion.  One reply said myfolder and another said myfolders.  I checked everything again and found that I had the path on the PC set correctly and specified correctly in the VM setup but left the 's' off the share name.  All is okay now


 

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 8 replies
  • 415 views
  • 2 likes
  • 3 in conversation