Learning SAS? Welcome to the exclusive online community for all SAS learners.

SAS UE

Reply
Frequent Contributor
Posts: 142

SAS UE

I have been using SAS UE for 2 yrs with no problems.  Recently due to the browser issue with google chrome and firefox my SAS EU would not run.  Working with SAS and community members, I was able to get it to run again.  However randomly when I launch I get the response from SAS studio: "Unable to create session temp directory."  

 

If I then close the VM machine and try again, it will run some of the code which are macros and I get a message that no space left on device.  However prior to the browser issue the code had run with no issues.  To conserve log space I have a procprinto log ='           file.lst' before the macro.

 

I have searched the community but no repots for this issue are posted.  Does anyone have a solution for this issue?

PROC Star
Posts: 629

Re: SAS UE

Posted in reply to jacksonan123

Sometimes virtual box update might cause an issue, try reverting back to the older version of Virtual Box and see if that resolves. Also try clearing cookie, not sure if this might be a problem. 

Thanks,
Suryakiran
Frequent Contributor
Posts: 142

Re: SAS UE

Posted in reply to SuryaKiran
I am using VMware Workstation and I have the same version 12 throughout my
issues with SAS UE.

I will try to clean up the cookies. Do you know exactly what memory space
that SAS EU operates from?
PROC Star
Posts: 629

Re: SAS UE

Posted in reply to jacksonan123
  • The SAS University Edition virtual image is configured to use 1GB of RAM and two processors. You can increase the RAM that is assigned to the SAS University Edition virtual image, but you should assign half (50%) or less of the available physical RAM. You cannot increase the number of processors that are assigned to the SAS University Edition virtual image.

https://support.sas.com/software/products/university-edition/faq/prerequisites.htm

Thanks,
Suryakiran
Super User
Posts: 23,998

Re: SAS UE

Posted in reply to jacksonan123

I think this mainly becomes an issue when SAS closes/crashes and then the work libraries are not cleared of. I don't believe that that's been fixed yet. 

 

I would reinstall SAS and set my work library to be my desktop when working with large datasets, not the virtual image, which is how it currently operates. 

 

I do this but adding a USER library. If you have a library named USER SAS defaults data to there instead of work by default when using single level names. 

 

Frequent Contributor
Posts: 142

Re: SAS UE

I have a few questions:

1. Exactly where are the work libraries located for SAS and can they be
manually cleared?
2. I have looked under C:\Users\Andre Jackson\Documents\Virtual
Machines\SAS-University-Edition and I see no libraries.
3. When you say reinstall SAS you mean the OVA file?
Super User
Posts: 23,998

Re: SAS UE

[ Edited ]
Posted in reply to jacksonan123

1. Right click on the library and select properties and it shows you the path. Its stored somewhere in the VM. You can clear it out manually for the current session but I doubt you can for leftovers because access to the VM is locked down and users do not have access. You can try the%cleanwork utility that SAS offers, but I'm not sure it'll work. Never tried it myself. 

 

2. This is a SAS definition of a library, which just means a folder. It has no relation to your desktop machine except for the myfolders and any other connection you've set up.

 

3. Yes, I mean delete the VM from Oracle and Re-import an ova file. 

 


@jacksonan123 wrote:
I have a few questions:

1. Exactly where are the work libraries located for SAS and can they be
manually cleared?
2. I have looked under C:\Users\Andre Jackson\Documents\Virtual
Machines\SAS-University-Edition and I see no libraries.
3. When you say reinstall SAS you mean the OVA file?

 

Frequent Contributor
Posts: 142

Re: SAS UE

I located the libraries in SAS studio under mylibraries, but they had
nothing and I saw no library file associated with the VMware workstation 12.

I did the new download with the same results.
Super User
Posts: 23,998

Re: SAS UE

Posted in reply to jacksonan123

@jacksonan123 wrote:
I located the libraries in SAS studio under mylibraries, but they had
nothing and I saw no library file associated with the VMware workstation 12.

I did the new download with the same results.

I'm not sure I understand what that means.

 

You set up the myfolders to the same previous location in your set up, correct?

Are you not seeing the programs/data sets you previously had? Did you previously have something set up in the auto exec that you need to recreate? 

 

 

Frequent Contributor
Posts: 142

Re: SAS UE

I did the new download but once launched I still have the space issue and I
did setup the myfolders to the same previous location.

I am not aware of anything that I previously set up in the auto exec so
there was nothing for me to recreate.
Super User
Posts: 23,998

Re: SAS UE

Posted in reply to jacksonan123
Are you getting the error before you run any code? Post a screenshot of the error please? The user library didn’t work?
Frequent Contributor
Posts: 142

Re: SAS UE

This is what I get when I try to log on using the updated Firefox browser.
Super User
Posts: 23,998

Re: SAS UE

Posted in reply to jacksonan123

@jacksonan123 wrote:
This is what I get when I try to log on using the updated Firefox browser.

Was there supposed to be an attachment?

Frequent Contributor
Posts: 142

Re: SAS UE

SAS UE runs under the virtual box or VMware workstation and when it crashes it seems to corrupt which ever one happens to be working.  The browser is not the issue.

 

The solution is to uninstall the virtual software and start over.  The issue is not with SAS UE but the virtual software.  Once the virtual software is reconfigures SAS UE works just fine.

Ask a Question
Discussion stats
  • 13 replies
  • 289 views
  • 0 likes
  • 3 in conversation