Learning SAS? Welcome to the exclusive online community for all SAS learners.

Quotation mark does not work in virtual lab

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 12
Accepted Solution

Quotation mark does not work in virtual lab

I am following Statistics 1 of module 1 and when I try to code in SAS Enterprise guide or in sas studio, the quotation mark does not work. I have a laptop from msi. Is anyone familiar with this problem?


Accepted Solutions
Solution
‎06-08-2018 09:49 AM
Occasional Contributor
Posts: 12

Re: Quotation mark does not work in virtual lab

We found out it all had to do with the keyboard language settings. When I changed these settings on my laptop to English USA, the problem with the quotation marks was solved. The other way around (changing the language of the keyboard in the virtual lab to dutch) does not work however. 

View solution in original post


All Replies
Super User
Posts: 24,028

Re: Quotation mark does not work in virtual lab


@Lyanne wrote:

I am following Statistics 1 of module 1 and when I try to code in SAS Enterprise guide or in sas studio, the quotation mark does not work. I have a laptop from msi. Is anyone familiar with this problem?


What does 'does not work' mean?

Occasional Contributor
Posts: 12

Re: Quotation mark does not work in virtual lab

It means that when I type a ' or a ", just a blank space appears. 

Super User
Posts: 24,028

Re: Quotation mark does not work in virtual lab

I've only seen this when using Citrix within a VM and then when I remote in the keyboard isn't set up so no punctuation works in that case.

 

Are you using Citrix at all or some other remote desktop option?

 


@Lyanne wrote:

It means that when I type a ' or a ", just a blank space appears. 


 

Occasional Contributor
Posts: 12

Re: Quotation mark does not work in virtual lab

I am not sure about what citrix is. I am working in the virtual lab of the sas university though and that is a virtual server. I can not find the keyboard settings in there.

It was my first thought that it is something with the keyboard settings in the virtual lab. On my laptop it selfs the language settings are Dutch, I am not sure if that be the problem why it is not working in the virtual lab. Do you know?

SAS Super FREQ
Posts: 9,436

Re: Quotation mark does not work in virtual lab

[ Edited ]

Hi: If you are taking a course that uses a Virtual Lab (like a Live Web course) or the SAS Academy for Data Science (that uses SAS Studio in the Virtual lab on Amazon), then your keyboard issues might need to be brought up to Tech Support.

Your Live Web class should have a Tech Support person assigned to the class. Your SAS Academy Virtual Lab has a link, on the right side of the course information for opening a track with the Virtual Lab Tech Support.

The SAS Academy for Data Science should have code already loaded on the VL drive for the Statistics 1 course. I believe the location is shown in the setup instructions. We don't recommend doing a copy and paste from the PDF file, which might have curly quotes, which, as Chris noted, can cause issues. You should already find programs in your class directory, if you are using the Amazon Virtual Lab.

Here's an example of the SAS Academy instructions for STAT1 setup:

setup_VL_SAS_Academy.png

  If you do have a keyboard problem and you are using either a Live Web class Virtual Lab or the SAS Academy for Data Science Virtual Lab, then you should contact the Virtual Lab Tech Support using one of the methods described above.

cynthia

Community Manager
Posts: 3,467

Re: Quotation mark does not work in virtual lab

Any chance that you copied/pasted some text that contains a "curly" quote?  Try deleting the quote characters and typing them over.  And let us know where you copied from (if this is the case) so our materials can be corrected.

Occasional Contributor
Posts: 12

Re: Quotation mark does not work in virtual lab

Posted in reply to ChrisHemedinger

I did not copy anything. It is just that when I type a ' or a " that a blank space appears instead of a quotation mark. It is possible however to copy the quotation marks from an explanation (like the one from the pop up if you type 'Title'). So that is how I work right know, just copy and pasting quotation marks. 

Solution
‎06-08-2018 09:49 AM
Occasional Contributor
Posts: 12

Re: Quotation mark does not work in virtual lab

We found out it all had to do with the keyboard language settings. When I changed these settings on my laptop to English USA, the problem with the quotation marks was solved. The other way around (changing the language of the keyboard in the virtual lab to dutch) does not work however. 

SAS Super FREQ
Posts: 9,436

Re: Quotation mark does not work in virtual lab

Thanks for sharing that information. I was not aware of the keyboard settings working that way.
Cynthia
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 9 replies
  • 482 views
  • 5 likes
  • 4 in conversation