Learning SAS? Welcome to the exclusive online community for all SAS learners.

Problem in running codes..too slow

Reply
Occasional Contributor
Posts: 8

Problem in running codes..too slow

Hi, I'm just starting to work on SAS University. I have the macros, codes, everything ok. When I run the codes, sometimes they run really fast. BUT sometimes it just keep running and no outcome. I have the spanish version, but the translation of the message would be something like "working in progress"..... and nothing. I re-start my session, my PC, but nothing. Does it happen to someone else? What can I do?

Valued Guide
Posts: 3,208

Re: Problem in running codes..too slow

Just seen one possible cause of looking running.......

The sasuser dataset is locked, you cannot store your own datasets in your own sasuser library (does not make sense as you read it).

When you still try to do that,   ... no pop-up is seen .... no error on processing is coming.  Yes it did once so I post this.
When it did come with an error note the correction is easy, but still needing to reset the sas session. Looking it has become corrupted somewhere.  

---->-- ja karman --<-----
Super User
Posts: 17,819

Re: Problem in running codes..too slow

Is it freezing running on the same code/data or on different datasets? Macros are notorious for hanging in my experience. 

Occasional Contributor
Posts: 8

Re: Problem in running codes..too slow

The same macros with the same data set.... I run them in different days and the time they take its really different. And sometimes they just dont run at all

SAS Employee
Posts: 35

Re: Problem in running codes..too slow

An update for University Edition is now available that should fix the occasional hang that users have experienced when submitting code.  See more info at

Ask a Question
Discussion stats
  • 4 replies
  • 1274 views
  • 0 likes
  • 4 in conversation