Learning SAS? Welcome to the exclusive online community for all SAS learners.

Output Dataset does not get displayed in SAS University Edition (Studio 3.4 ,9.4M3) when using Dictionary.Columns table

Reply
Frequent Contributor
Posts: 86

Output Dataset does not get displayed in SAS University Edition (Studio 3.4 ,9.4M3) when using Dictionary.Columns table

All,

            This looks to me as though it is an Issue related to the SAS University Software (SUE) itself but when i run this simple query in the Latest Release of SUE (Studio 3.4 ,SAS 9.4M3)  i cannot see the Dataset which is created. The code Runs Successfully.

Proc Sql;

create table TEMP as

select *  from dictionary.columns

where LIBNAME='SASHELP'

and MEMNAME='CLASS';

Quit;

This is the SAS Log :

1 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK;

55

56 Proc Sql;

57 create table TEMP as

58 select * from dictionary.columns

59 where LIBNAME='SASHELP'

60 and MEMNAME='CLASS';

NOTE: Table WORK.TEMP created, with 5 rows and 18 columns.

61 Quit;

NOTE: PROCEDURE SQL used (Total process time):

  real time 0.00 seconds

  cpu time 0.00 seconds

If I add a PROC PRINT after the above then i can see the Contents of the Dataset TEMP. I have sent an email to SAS Tech Support on this but would like to make sure if others too are facing the same Issue.  The Issue is related to the use of the Dictionary.Columns  table

If anyone has the latest release of SUE can you please try the above code and see if you can see the Output Dataset?

Thanks.

Super User
Posts: 17,745

Re: Output Dataset does not get displayed in SAS University Edition (Studio 3.4 ,9.4M3) when using Dictionary.Columns table

Can you post a screen shot of your Work library that doesn't show the dataset?

Frequent Contributor
Posts: 86

Re: Output Dataset does not get displayed in SAS University Edition (Studio 3.4 ,9.4M3) when using Dictionary.Columns table

Actually Reeza, I do see the Dataset  in the WORK Library but i cannot see its contents being displayed in the SAS Studio 3.4. As soon as I run the Code in  SAS Studio 3.4  it  should show me the Dataset TEMP contents ie Columns and Rows. This is NOT happening. Also if I go to the WORK Library and try opening the TEMP dataset it  gets displayed as Blank page in SAS Studio 3.4.

I am unable to attach the Screenshot something is going with this Community Forum Today.Maintenance i guess .

Super User
Posts: 17,745

Re: Output Dataset does not get displayed in SAS University Edition (Studio 3.4 ,9.4M3) when using Dictionary.Columns table

I get the same behaviour you're experiencing.

The data does not display automatically after running the code in the OUTPUT DATA window.

If I try and open the data set from the work library it does not display either. 

If I use a proc print I can see the data.

If I save the data to another data set I cannot see or open the data.

Proc Sql;

create table TEMP as

select *  from dictionary.columns

where LIBNAME='SASHELP'

and MEMNAME='AIR';

Quit;

proc print data=temp(obs=5);

run;

proc setinit;

run;

Current version: 9.04.01M3P062415

Site name: 'UNIVERSITY EDITION 2.2 9.4M3 WITH ETS FOR PLAYER'.

Site number: 70186327.

CPU A: Model name='' model number='' serial='+2'.

Expiration: 15JUN2016.

Grace Period: 0 days (ending 15JUN2016).

Warning Period: 46 days (ending 31JUL2016).

System birthday: 02JUL2015.

Operating System: LIN X64 .

Product expiration dates:

---Base SAS Software 15JUN2016 (CPU A)

---SAS/STAT 15JUN2016 (CPU A)

---SAS/ETS 15JUN2016 (CPU A)

---SAS/IML 15JUN2016 (CPU A)

---SAS/ACCESS Interface to PC Files 15JUN2016 (CPU A)

---SAS/IML Studio 15JUN2016 (CPU A)

---SAS Workspace Server for Local Access 15JUN2016 (CPU A)

---SAS Workspace Server for Enterprise Access 15JUN2016 (CPU A)

---High Performance Suite 15JUN2016 (CPU A)

data temp2;

set temp;

run;

Frequent Contributor
Posts: 86

Re: Output Dataset does not get displayed in SAS University Edition (Studio 3.4 ,9.4M3) when using Dictionary.Columns table

Thanks for Confirming this Reeza. Sorry may not have been very Clear in the beginning. I actually sent this to SAS Tech Support.  They wanted me to post it in this Discussion Forum to get a solution thinking this is a USAGE Issue  but i let them know that this is not USAGE Issue but a Possible Bug .The Bug  i am thinking lies  with  the Dictionary.Columns  table  because even  when i tried to open the VCOLUMN  view within  the SASHELP Library i get a blank page in SAS Studio 3.4  . I can however successfully open the views VTABLE,VMACRO etc .

Ask a Question
Discussion stats
  • 4 replies
  • 436 views
  • 0 likes
  • 2 in conversation