Learning SAS? Welcome to the exclusive online community for all SAS learners.

MyFolders Warning

Reply
Contributor
Posts: 27

MyFolders Warning

After starting the virtualbox and going to localhost:10080 and arriving at the SAS Information Center, there's a message that says "A shared folder name "myfolders" was not found on the virtual machine.  See the FAQ for details."  However I've created the folder and have shared it per the instructions as best as I can tell.  What's also curious is that when I get into SAS Studio and expand the Folders section on the left, I have two entries under "My Folders": one is sasuser.v94 and the other is a dataset I created after issuing a libname statement for '/folders/myfolders'.  However when I go to Windows Explorer I see nothing there.  It's clearly saving it somewhere but I don't know where.

Thanks,

Steve James

spj1@cdc.gov

N/A
Posts: 1

Re: MyFolders Warning

I received the same message, "A shared folder name "myfolders" was not found on the virtual machine.  See the FAQ for details." I am going to do some research and see if I can figure this out and I'll keep checking back here to see if any one will respond. If not I will be sure to answer the question when I find out.

Cordially,

Sheena Burgess

New User
Posts: 1

Re: MyFolders Warning

i am creat a my folders but problem is same . The message is always display my computer.

 

New Contributor
Posts: 2

Re: MyFolders Warning

I have the same problem, I've already update the SAS university software and the virtual machine software, re -create the sas folder called "myfolders" but nothing works. I have no access to my ecxel data and only have two month to finish my paper.

I really appreciate any help in this issue.

sorry about my English and thank you.

Raul Carmona.

SAS Super FREQ
Posts: 8,744

Re: MyFolders Warning

Hi, Steve:

  On my physical Windows machine, I have a directory structure of:

c:\SASUniversityEdition\myfolders

That is the full path that I set up as my shared folder. So if I have secondary folders and a few files in that location, like:

c:\SASUniversityEdition\myfolders\sasdata\customers.sas7bdat

c:\SASUniversityEdition\myfolders\rawdata\orders.txt

Then assuming I have shared the high level path, I only need to do this:

libname stuff '/folders/myfolders/sasdata';

proc print data=stuff.customers;

run;

or

data neworders;

  infile '/folders/myfolders/rawdata/orders.txt';

  input .....;

run;

proc print data=work.neworders;

run;

And I am able to read the files with no issues. Somehow, I fear that you either shared the wrong high level path OR you did not make a physical folder called "myfolders" as part of the path in the shared location.

cynthia

Regular Learner
Posts: 1

Re: MyFolders Warning

Did U Linked Files Library to Folders on a flash drive?

In the Answer to the above question you will find your answer for the posted problem.

Occasional Learner
Posts: 1

Re: MyFolders Warning

[ Edited ]

I think this is a problem that many people who are beginning to use this system encounter. I did face the problem initially.

 

What worked for me was to always ensure that before connecting to my SAS University software (by entering the address http://localhost:10080 in my browser), I link/map “myfolders” on my laptop location (I saved it on drive D just incase there is need to format drive C in which case I will not loose data stored on drive D) to the SAS University software (studio). Note: You have to do this every time before visiting http://localhost:10080.If you do this then the error message does not appear. If the message is still there just map the folder again and refresh your browser and the error message disappears.

 

 

Hope this helps.

 

Cheers.

Jonathan Matheka

https://ke.linkedin.com/in/jonathan-matheka-38539256

SAS Super FREQ
Posts: 361

Re: MyFolders Warning

 

You should only need to create a myfolders Shared Folder once.

 

When you create the Shared Folder, make sure you select the checkbox to make it Auto-mount and Full (read/write) access.

 

If you do this, VirtualBox should recognize the presence of this Shared Folder, and SAS University Edition should not give you a warning.

 

If you think you've created the myfolders Shared Folder but you do not see the same files in your Windows Explorer/Macintosh Finder folder as you see in your SAS Studio interface, something isn't right.

 

You don't want to store files in your virtual machine. If you do that, then when you upgrade, you will overwrite you files.

 

Two other tips: 1) Please name the folder to be myfolders -- no space, all lower-case; 2) It's not strictly necessary, but it is best to create the Shared Folder when the virtual machine is powered off.

 

Here's all the info you should need:

https://support.sas.com/software/products/university-edition/faq/shared_folder_virtualbox.htm

 

Hope this helps!

Randy

 

 

New User
Posts: 1

Re: MyFolders Warning

[ Edited ]

Open virtual machine

right click on SAS UV Edition 

go to settings>options>sharedfolders

change the name to ''myfolders'' >ok.

now download update. Smiley Happy

 


Capture.PNG
Ask a Question
Discussion stats
  • 8 replies
  • 1728 views
  • 0 likes
  • 9 in conversation