Learning SAS? Welcome to the exclusive online community for all SAS learners.

Library Path "/" changing to "\" for Windows Version University SAS

Reply
New Contributor
Posts: 2

Library Path "/" changing to "\" for Windows Version University SAS

When trying to establish a file name for a dat file named althealt.dat, I am getting the following error message:

ERROR: Physical file does not exist, /opt/sasinside/SASConfig/Lev1/SASApp/C:/SASUniversityEdition/MyFolders/althealt.dat.


How do I get University SAS to look directly to the shared folder instead of defaulting to the /opt/sasinside/SASConfig/Lev1/SASApp path prior to my assignment?


Code used is as follows:


FILENAME ASCIIDAT 'C:/SASUniversityEdition/MyFolders/althealt.dat';


Inside the Data Step:  INFILE ASCIIDAT PAD LRECL=1086;


I configured my did configure the virtual machine to share the folder C:/SASUniversityEdition/MyFolders, but when I try to get the update for University SAS, I get a message stating that myfolders is not present.


Thanks,

JAAAR

Super User
Posts: 17,912

Re: Library Path "/" changing to "\" for Windows Version University SAS

You're incorrectly specifying your path. Since your on a VM and a Unix machine you use unix paths.

This is explained in the documentation as well as in this thread here, see Cynthia Z answer.

New Contributor
Posts: 2

Re: Library Path "/" changing to "\" for Windows Version University SAS

I appreciate the direction.

UNIX is not my native platform, and I am still getting an error Smiley Happy

FILENAME ASCIIDAT '/folders/myfolders/althealt/althealth.dat'; /* This state is Executing without error */

My error is still generated in the data step: ERROR: Physical file does not exist, /folders/myfolders/althealt/althealth.dat

INFILE ASCIIDAT PAD LRECL=1086;

Please forgive my ignorance over something simple that I am clearly missing.

Thanks,

--Jeff

Super User
Posts: 17,912

Re: Library Path "/" changing to "\" for Windows Version University SAS

The VM that SAS UE is on is a Unix machine, and requires Unix paths.

Did you set up the shared folder as in the setup instructions?

If so show the screen shot of the My Folders and the altheal data set. In your original code you didn't use an althealt folder...

/folders/myfolders/althealt.dat

Super User
Super User
Posts: 7,413

Re: Library Path "/" changing to "\" for Windows Version University SAS

You may want to check your typing.  Your error is telling you that althealth.dat is missing, however in your first post, the file is called althealt.dat, without the final h.  Check all your typing/path names to ensure they are correct and point to the right place.

New Contributor
Posts: 3

Re: Library Path "/" changing to "\" for Windows Version University SAS

As I can understand you have a 'MyFolders' folder shared for your VM mAchine now you need to put the file under MyFolders.

Once you place the file under the folder and refresh it on the left hand side you will see one refresh button your file will be visible under your shared folder.

Then right click on that file you will see property option this will show you the path of your file.

Currently you are using wrong path to locate the file.

Path will be like this: '/folders/myshortcuts/MyFolders'

Thanks.

Ask a Question
Discussion stats
  • 5 replies
  • 367 views
  • 0 likes
  • 4 in conversation