Learning SAS? Welcome to the exclusive online community for all SAS learners.

How do I turn off output in Studio/University Edition?

Accepted Solution Solved
Reply
Contributor
Posts: 65
Accepted Solution

How do I turn off output in Studio/University Edition?

I'm a veteran SAS user learning how to use the University Edition so I can teach SAS to my community of students and academics.  I process the datasets from procs like Mixed, so I want to turn off the output.  Unfortunately ods listing close , ods html close , ods html3 close etc. do nothing.  Is there any way to turn off the output (and turn it on again, of course)? 

 

I've also found that title2, title3 etc. get ignored.  All I get is one title line.  Any help here?

 

Finally, a very interesting feature...  Any programs I have been running simply disappear if I've been away from the laptop for a while! 

 

Will


Accepted Solutions
Solution
‎06-20-2016 06:55 PM
Super User
Posts: 17,837

Re: How do I turn off all output except graphics in Studio/University Edition?

If you have new questions you should post it as a new thread.

 

In your case, you need to select only the one of interest, so you need to find the name of the output and include it in your select statement.

 

ODS SELECT <output>;

You can find the table names by running your proc with all results using ODS TRACE. The log will include the names. 

 

ODS TRACE ON;

<proc mixed code>

ODS TRACE OFF;

View solution in original post


All Replies
Super User
Super User
Posts: 7,401

Re: How do I turn off output in Studio/University Edition?

Try:

ods noresults;

Super User
Posts: 9,681

Re: How do I turn off output in Studio/University Edition?


ods _all_ close;
proc reg data=sashelp.class;
model weight=height;
quit;

Super User
Posts: 17,837

Re: How do I turn off output in Studio/University Edition?

ODS Select none;

 

re loss of code/results, that's an unfortunate result of using a browser based interface. When the browser refreshes you lose your work. So save often Smiley Happy 

 

SAS Employee
Posts: 146

Re: How do I turn off output in Studio/University Edition?

You have some good answers already to the turning off the output question.  You'll find a bit more detail in the Studio documentation at http://support.sas.com/documentation/cdl/en/webeditorug/68828/HTML/default/viewer.htm#n0lyxx45gr31pa... .  Also know that you can go to preferences in Studio to turn off some of the default output that's generated.

 

I don't understand why you would be losing TITLE statements.  Titles do not persist across different program tabs but your titles should stay put within each tab/program.

 

As for losing your program, http://support.sas.com/software/products/sasstudio/faq/code_closebrowser.htm talks through what happens when your session disconnects.  Studio does have an auto-save but you have to first save to a file before that will kick in.  And if you have something you need to run that you want to be able to disconnect & have it continue running, check out the batch submit (really it's a background submit - we'll probably change the name to make it more clear in a later release) feature - http://support.sas.com/documentation/cdl/en/webeditorug/68828/HTML/default/viewer.htm#n0t5b6xetubfnz...

Contributor
Posts: 65

Summary: How do I turn off output in Studio/University Edition?

Thanks for all the feedback. This is obviously going to be a useful forum.

 

I can now turn off the output, but I can’t turn it on again in the program. 

 

ods noresults;

This didn't work. All I got in the log was:

NOTE: ODS statements in the SAS Studio environment may disable some output features.

 

ods _all_ close;

This turned off the output. It had reset all by itself the next time I submitted something producing output, which is fine. However, I was unable to turn on the output with ods html; within the program, so that’s no good. Here’s the error message:

94         ods html;

NOTE: Writing HTML Body file: sashtml17.htm

ERROR: Insufficient authorization to access

/opt/sasinside/SASConfig/Lev1/SASApp/sashtml17.htm.

ERROR: No body file. HTML output will not be created.

 

ods select none;

This turned off the output, but nothing I could do turned it on again. I had to sign out and sign in again.

 

There was nothing in the Preferences for turning off Results. In any case, I need to do it in the program.

 

Re my problem with title1, title2… No problem today.  Sorry about that.

 

Re my problem with losing a program after time away from the laptop…    Unclear why the University Edition should have a time-out interval, but there it was, in the Preferences, set to 1 hour by default.  I have now set it to 24 hours.

 

So, I hope someone can solve the problem of turning ON the output to the html Results window again. The usual output from Proc Mixed with all the datasets I produce is just way too cluttered. Bring back noprint.

 

Will G Hopkins, PhD FACSM FECSS

Contact info and citations: http://sportsci.org/will

Sportscience: http://sportsci.org

Statistics: http://newstats.org

Be creative: break rules.

 

 

 

 

Super User
Posts: 17,837

Re: Summary: How do I turn off output in Studio/University Edition?

All those commands have the opposite. 

 

Ods results;

 

ods HTML;

 

ods select all;  

 

Dependinf on which one you used, use the corresponding command to turn it back on. I would suggest first or third as I'm not sure what the default destination is called. 

Valued Guide
Posts: 505

Re: Summary: How do I turn off output in Studio/University Edition?

How to save your work (not applicable to EE, UE, SAS Studio or EG). Need the more powerfull old SAS ISPF like editor.

 

I am not that familiar with the new interfaces ie EG, SAS Studio and SAS UE, however in the old SAS(ISPF) text editor, If I hit the middle mouse button  a time stamped version(up to the second)  of the current program is saved in c:/ver and a production version in c:/utl.

 

I also set autosave to every 60 seconds, saving the program in c:/ver/pgm.sas. It takes a little setup to do this but once done it works forever even when you install a new version of SAS, unlike EG where I usually lose my profile with each new EG version and they are more frequent than SAS versions.,

 

Here is the setup

 

Make this the first line of your program

 

%let pgm=utl_helloworld;

 

put this line in your autoexec

 

%Let _q=%sysfunc(int(%sysfunc(time())));

 

type keys on the old text editor command line(not the command bar)

and type the text opposite 'MMB'

 

pgm;file &pgm..sas;file c:\ver\&pgm.&_q..sas;%let _q=%eval(0&_q +1);

 

Now everytime you hit the middle mouse button the program will be saved as

 

utl_hellowworld in c:/utl

 

and

 

utl_hellowworld167847.sas (where 167847 is number of seconds into the day)

 

You may think you will be saving too often, but even with this easy versioning you probably will not save often enough

 

 

 

 

 

 

SAS Super FREQ
Posts: 8,743

Re: Summary: How do I turn off output in Studio/University Edition?

[ Edited ]

Hi, As Reeza explained, ODS SELECT NONE will cause no output objects to be routed to ODS; while ODS SELECT ALL will cause ALL output objects to be routed to the open destinations. Please see this example:

 

ods_select_all_none.png

 

As you can see, only outputs 1 and 3 were routed to the default destination.

 

If you do accidentally issue or on purpose issue ODS _ALL_ CLOSE, then you can turn on the default collection of HTML again. But if you do a simple ODS HTML; then the chances are good that ODS in a Virtual Machine will use a "default" path location that is read-only and you will not be able to write to that location, as you showed in your error message.

 

But you have several choices for "redirecting" the output:

1) sign out and sign back in (probably my last choice)

2) specify the PATH= to a folder where you do have write access and take the default name;

html_use_automatic_name.png

 

 

3) specify PATH= and FILE= to take full control of the name

ods_html_full_control.png

 

4) go to the Preferences --> Results Window and click Reset to Defaults -- after I had issued an ODS _ALL_ CLOSE: using this button made my next output appear in the Results window.

reset_defaults.png

 

I don't know what's up with your TITLE, unless you inadvertently have a null title statement someplace in the code. As you see in the first screen shot, I have 2 TITLE statements for each procedure and both titles show in my Results.

 

cynthia

Contributor
Posts: 65

How do I turn off all output except graphics in Studio/University Edition?

See below for my responses to previous postings. I now have another problem: I love the residuals plots that Mixed produces, but I want to suppress all the other output and deal with it via ods output tables.

 

I expected this to work, but no graphics were output:

ods select none;
ods graphics / imagemap=on;

proc mixed plots=(residualPanel) etc;

etc;

run;

ods select all;

 

I want the graphics to go to the RESULTS window.

 

Re previous posting...

Reeza: I apologize for not being able to figure out for myself that ods select all turns everything back on after ods select none turns it off.

rogerjdeangelis: Thanks for all that code, but too difficult for me at this stage. It's as bad as R!  I'm just trying to get Studio to produce uncluttered output for my community.

Cynthia_SAS: Thanks for those tips on specifying PATH= and FILE=. Problem with title2 etc. was again me being stupid.

 

Will

Solution
‎06-20-2016 06:55 PM
Super User
Posts: 17,837

Re: How do I turn off all output except graphics in Studio/University Edition?

If you have new questions you should post it as a new thread.

 

In your case, you need to select only the one of interest, so you need to find the name of the output and include it in your select statement.

 

ODS SELECT <output>;

You can find the table names by running your proc with all results using ODS TRACE. The log will include the names. 

 

ODS TRACE ON;

<proc mixed code>

ODS TRACE OFF;
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 10 replies
  • 1014 views
  • 0 likes
  • 7 in conversation