Learning SAS? Welcome to the exclusive online community for all SAS learners.

Code hanging at "Running"

Reply
Occasional Contributor
Posts: 5

Code hanging at "Running"

Is anybody else having issues with code hanging at "Running"? These are simple codes that should not take much processing time. All the codes include a run; statement, and it is occurring on multiple platforms on multiple machines (Mac OS X, Windows, etc.). We usually have to resort to ending the session and restarting it, and that usually does the trick, but not always. It's becoming very frustrating.

Super User
Posts: 10,527

Re: Code hanging at "Running"

Do you have a macro involved anywhere? Also look at any loop code, especially Do Until or Do While loops as you may be not meeting the end condition.

Occasional Contributor
Posts: 5

Re: Code hanging at "Running"

It is literally a proc print step, no other statements other than run. No macros or do loops.

Super User
Posts: 10,527

Re: Code hanging at "Running"

How many records? Extremely large tables can take quite awhile to build and render in HTML on occasion.

Occasional Contributor
Posts: 5

Re: Code hanging at "Running"

Maybe 75 observations, 9 variables. Very small tables.

SAS Super FREQ
Posts: 8,743

Re: Code hanging at "Running"

Hi:

  Since you refer to the code hanging on multiple platforms and/or multiple machines, including the Mac, does that mean you are running SAS using the SAS University Edition in a Virtual Machine? If so, I believe the University Edition Virtual Machine does have a timeout limit. I have experienced some issues with "hanging" when I've stepped away and then come back (usually for lunch or after a period of inactivity). I believe you can set the timeout limit in the Virtual Machine software. And of course, not having the correct step boundary, always messes me up too (like not using a QUIT; for procedures like PROC DATASETS). But with what you report (trouble with a PROC PRINT), trouble with a step boundary seems less likely than a timeout of some kind. Or, you might think you are selecting all the code, but instead have only the first line selected when you hit Submit as described here https://communities.sas.com/message/214995#214995.

  At any rate, you might want to open a track with Tech Support on this issue, since this is something they might need to investigate in more depth.

cynthia

Occasional Contributor
Posts: 5

Re: Code hanging at "Running"

I am running University Edition on VirtualBox. I don't think it's a timeout issue. If I log off or reset the SAS session, the code will run fine.

I have opened a ticket with tech support, and I will update this thread when I get a response.

Super User
Super User
Posts: 6,502

Re: Code hanging at "Running"

Did you include the RUN; statement to tell SAS they you had finished telling it how you wanted the PROC PRINT to run? 

Perhaps you submitted unbalanced quotes or missing semicolons that caused the RUN; statement to be "eaten".

Regular Contributor
Posts: 187

Re: Code hanging at "Running"

I get this too - my syntax is correct, small data sets etc and it seems almost random. Sometimes resetting the SAS session clears it, sometimes not; sometimes restarting the VM will clear it and sometimes not. Sometimes I have to actually close the VM and start from scratch to get back to a working session. It also happens sometimes when I've just started the session so it's definitely not a time out issue.

I'm running on an iMac with VMWARE Fusion 6 through Safari if that makes a difference..........

Contributor
Posts: 23

Re: Code hanging at "Running"

Hi hankim, We were having the same problem across multiple machines. Weirdly, we found if we used Chrome as opposed to Firefox or IE, it was less likely to happen.

New Contributor
Posts: 2

Re: Code hanging at "Running"

Hi All,

There appears to be a bit of fragility in the AnalyticsU and SAS Studio release at present.

It can happen very quickly and does not seem to be ralated to what you are trying to do..

Whilst I was at SAS Analytics 2014 in Frankfurt a couple of weeks ago, the super-demo using the local PC SAS Server at lunchtime froze part way through the demo. The demonstrator said that this was a known issue.

The only solution is to re-start the VM session.

The second super-demo, using a remote server for SAS Studio worked well the following day.

Richard

N/A
Posts: 1

Re: Code hanging at "Running"

I am having the same issue. I am using SAS university edition with virtual box from Mac. Please let me know if you figure out the problem. I am not sure if it is a session time out problem or something else, it keeps on running for a simple Proc print statement.

Thanks!

Occasional Contributor
Posts: 5

Re: Code hanging at "Running"

We are still having the issue, although it seems more stable on Chrome than Safari (no real data, just a gut feel). We also simply restart the session using the "Restart SAS Session" option under the menu next to the Sign Off button on the top right. It's a lot quicker than signing off and restarting SAS.

Frequent Contributor
Posts: 83

Re: Code hanging at "Running"

This happens to me running SAS UE.  on windows 7 HP PC.

Reported earlier here by Jenny

Seems to be a resource problem as resetting the SAS session usually fixes it.

I also get error messages 'Unable to open parameter catalog: SASUSER.PARMS.PARMS.SLIST'

Hopefully Tech support can find a fix for it. 

Jim

Valued Guide
Posts: 3,208

Re: Code hanging at "Running"

I have seen several problems now.
- placing a empty sas dataset in sasuser does not cause any errors. When the dataset is filled session hangs.

  There should ben error coming up with the not being authorized. The sasuser is blocked for write access.

  The problem is the missing error. When the session is restarted the error will come with no hangup.

- Doing a cut/paste from is communities site tot he UE source editor sometimes is crashing the editor completely.

  All synchronization is wrong double cursors and the code behind is not what you see on the screen.
  Restarting the session solves the issue.

- Viewing a daaset then updating it an review that one again does not show the real content.

  After a refresh it is updated.

Looks the synchronization between the browser and SAS studio is not always what is expected as reliable.

---->-- ja karman --<-----
Ask a Question
Discussion stats