Don't just think like a data scientist. Be one.

Impute node error in practice exercise - Applied Analytics using Enterprise Miner - Lesson 5

Reply
New Contributor
Posts: 4

Impute node error in practice exercise - Applied Analytics using Enterprise Miner - Lesson 5

[ Edited ]

Hello,

 

I think I am following instructions for exercises but somehow I am getting an error when trying to run Impute node.

Error says: "Maximum target levels of 512 exceeded. Training will not be performed".

 

Am I the only person experiencing this error?

Also worth mentioning, that when creating trees in previous lesson, my second tree had different results compared to the one presented in Solution.

When it comes to ORGANICS data source, Nieghbourhood variable did not get Rejected by default like it has been mentioned in solution.

 

Would be grateful for help, thanks!

 

EDIT:

Taking into account problems with Neighbourhood variable, I went back to Data source and have set CustID to have ID role and Region to have Rejected role. This caused Impute to run with no errors and also now I have the same number of leaves in second tree from lesson 4 (34, had 36 before making changes mentioned).

SAS Super FREQ
Posts: 9,365

Re: Impute node error in practice exercise - Applied Analytics using Enterprise Miner - Lesson 5

Posted in reply to kibicrealu1

Hi:

  It appears from your added comment that you might have figured out the issue with the exercise. However, Theresa asked the instructors for the class for feedback and here is the feedback she received (I am posting this on her behalf, as she had other commitments):

 

==== Comments ====

Notes tell you to set the role of TargetAmt to rejected

 

and

 

When you see the "Maximum target levels of 512 exceeded. Training will not be performed" message, you should first think, “How could my binary target variable have more than 512 levels?” It is almost always a metadata problem. Make sure that binary target variables have the level set to binary, and that interval target variables have the level set to interval. If you create the input data source for Organics using the advanced advisor, it sets TargetAmt as role=target and level=nominal. (Why level=nominal? Select the “Customize” button next to the advanced option and you will get the answer.)

TargetAmt is a count variable indicating how many organics items were purchased. It takes values 0, 1, 2, and 3. TargetAmt should have an interval level.

  

One of the challenges in teaching analytics is to convey specific factual information while also providing realistic analysis scenarios. There is no right answer, so matching the results in the course notes is only important to the extent that you understand the factual information related to applying analytics and using SAS Enterprise Miner. If your results do not match, it could be because

  1. You did not specify the exact properties that were specified in the notes.
  2. The metadata for the training data does not match that used in the course notes.
  3. You are using a different version of the software.
  4. You are using a different “version” of the data. In rare cases, the sort order of the observations can affect the training results.
  5. The course notes have a typographical error. [This is the least likely cause.]
  6. You are using different hardware than was used to create the course notes. Single machine mode can yield numeric results different than distributed processing. The HPDM nodes take advantage of any distributed processing capabilities that are available.

I conjecture that the variable selection problem is tied to the metadata problem. 

 

==== ====

 

  If the above does not help with the exercise, please do post again and let us know.

 

Cynthia

 

 

 

 

Ask a Question
Discussion stats
  • 1 reply
  • 206 views
  • 0 likes
  • 2 in conversation