The SAS Output Delivery System and reporting techniques

tagsets.tableeditor frozen headers not working in stored process output

Reply
Occasional Contributor
Posts: 12

tagsets.tableeditor frozen headers not working in stored process output

I am attempting to get a table created by a stored process to render with frozen column headers.   I have referred to a number of support documents that explain ODS TAGSETS.TABLEEDITOR and only get partial success with the options.   For example, autofilter="yes" does work in both IE 11 and Firefox 30, but frozen_headers ="yes" and  frozen_rowheaders="1,2" don't seem to work, either separately or together.    I have tried setting table height and width to ensure the table would not fill up the screen (what a mess looking at Google Chrome).  I am creating the stored process using Enterprise Guide 4.3.   When I look at the examples presented in the document Creating a Data Grid Like VB.NET, the frozen_headers.htm example also does not work.   I was thinking I might have a local environment issue, but some of these options do work, so I'm stuck as to why the frozen headers won't work.   Any ideas?    Thanks.

SAS Super FREQ
Posts: 8,864

Re: tagsets.tableeditor frozen headers not working in stored process output

Hi: TAGSETS.TABLEEDITOR works by embedding JavaScript in the HTML output. So first, if you are receiving the stored process output in a browser, JavaScript and scripting have to be allowed. When you create a stored process, your stored process could be run in PowerPoint (for example), but it would be a fruitless effort, in which the HTML/JavaScript is not used. PowerPoint, for example, can only receive SASReport XML type reports from stored processes.

  My suspicion is that you have some kind of client application/HTML/JavaScript problem. The only folks who can debug that are Tech Support.

cynthia

Occasional Contributor
Posts: 12

Re: tagsets.tableeditor frozen headers not working in stored process output

Posted in reply to Cynthia_sas

I have tried on both PC and Mac using IE, Firefox and Chrome on PC and Safari, Firefox and Chrome on Mac.   I have done this from different locations.  In none of the browsers does the frozen headers example work from this document:  Base SAS: Creating a Data Grid Like VB.NET

If there is some kind of HTML issue/JavaScript issue, it seems to have widespread impact that is really unrelated to whether I created the file in a stored process.  I assume you mean contact SAS Tech Support.   I'll do that.   Thanks.

Occasional Contributor
Posts: 16

Re: tagsets.tableeditor frozen headers not working in stored process output

hi pylon53,

I have the same issue.

If I try the example for frozen headers from  Base SAS: Creating a Data Grid Like VB.NET, it works from SAS Eguide (program running running on unix server).

But if I use it in a web-application STP (file=_webout), it doesn't. In the generated source is NO javascript.

Did you get any further?

thanks.

 

Ask a Question
Discussion stats
  • 3 replies
  • 579 views
  • 0 likes
  • 3 in conversation