The SAS Output Delivery System and reporting techniques

proc report #byval

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 6
Accepted Solution

proc report #byval

Hi, 

 

I currently use a macro to pull in all title and footnotes(holds in googledoc), and depending on which programs that is running, the relavent title and footnote will be selected.  

 

I have tried with the compute before _page_, however I would like the title2 to be outside of the table, and underneath the rest of the titles.  

 

After reading some of the papers, I have put #byvar(xx) into the title2 column and my proc report is: 

 

proc report data = mydata nowindows headline headskip split='~'
missing spanrows style(header)={just=l} spacing=4;
columns dummy1 dummy2 dummy3 dummy4 dummy5;
by xx;
define ......
run;

 

then in the output( PDF and RTF), I get(i.e by value is Full analysis set) 

                      xx= Full analysis set 

studycode:xxxxxx

table xxxxx

Full analysis set

                   xx=Full analysis set

 

my question is : 

1. Why does the text highlighted in red appear?  

2. I suspect it could be my own macro problem, but the text in red only appear twice when it is the first page of a new set of sub-data. i.e. first page of full analysis set information, second page will only show the one at the bottom. 

 

 

I have attached the screenshot, highlighted part is the one that I want to get rid off, but dont know how! 

Would be greatful if someone could give me some suggestions?

 

Thanks 

Michelle 

     

Attachment

Accepted Solutions
Solution
‎04-22-2017 03:30 PM
SAS Super FREQ
Posts: 8,643

Re: proc report #byval

Hi:
You don't show all your code, including your options and your ODS statements. I suspect you need
options nobyline;
before your ODS invocation. Typically, when you use #byval or #byvar, you turn OFF the default byline.

But without data to test or your full code, that is just a guess.
cynthia

View solution in original post


All Replies
Solution
‎04-22-2017 03:30 PM
SAS Super FREQ
Posts: 8,643

Re: proc report #byval

Hi:
You don't show all your code, including your options and your ODS statements. I suspect you need
options nobyline;
before your ODS invocation. Typically, when you use #byval or #byvar, you turn OFF the default byline.

But without data to test or your full code, that is just a guess.
cynthia
Occasional Contributor
Posts: 6

Re: proc report #byval

Hi cynthia, 

 

you were spot on! I did not have the options nobyline in the proc report!!! 

 

I have since add that option into my proc report and it works perfectly! 

 

thank you very much, I must have issed the option in the paper!! 

 

Regards

Michelle 

Post a Question
Discussion Stats
  • 2 replies
  • 143 views
  • 0 likes
  • 2 in conversation