The SAS Output Delivery System and reporting techniques

how to turn off automatic opening of rtf document with ODS

Accepted Solution Solved
Reply
N/A
Posts: 1
Accepted Solution

how to turn off automatic opening of rtf document with ODS

Hi

I'm using SAS 9.4 and I create many different rtf document with a macro in SAS using ODS features.

But, after creating a rtf document on my hard drive, SAS automatically opened it. It quickly run out my memory. How can I switch off the automatic opening.

For example:

DATA CLASS;

     INPUT NAME $ 1-8 SEX $ 10 AGE 12-13 HEIGHT 15-16 WEIGHT 18-22;

CARDS;

JOHN    M  12 59 99.5

JAMES   M  12 57 83.0

ALFRED  M  14 69 112.5

ALICE   F  13 56 84.0

;

ods rtf file= "D:\TestSAS\OUT\_test.rtf" ;

PROC MEANS;

     VAR AGE HEIGHT WEIGHT;

PROC PLOT;

     PLOT WEIGHT*HEIGHT;

quit ;

ods rtf close ;

will automatically open the _test.rtf document in Microsoft word

Thank you for your help,

all the best,

Damien.


Accepted Solutions
Solution
‎07-09-2015 11:33 AM
SAS Super FREQ
Posts: 8,740

Re: how to turn off automatic opening of rtf document with ODS


Hi:

  Go to Tools --> Options --> Preferences ---> Results tab. On the Results Tab, look for the check box that says: "View results as they are generated" -- make sure that you clear the check mark that appears in that box. That should stop SAS from automatically launching Word when the RTF file has been generated.

cynthia

View solution in original post


All Replies
Solution
‎07-09-2015 11:33 AM
SAS Super FREQ
Posts: 8,740

Re: how to turn off automatic opening of rtf document with ODS


Hi:

  Go to Tools --> Options --> Preferences ---> Results tab. On the Results Tab, look for the check box that says: "View results as they are generated" -- make sure that you clear the check mark that appears in that box. That should stop SAS from automatically launching Word when the RTF file has been generated.

cynthia

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 1 reply
  • 738 views
  • 0 likes
  • 2 in conversation