The SAS Output Delivery System and reporting techniques

can't display ODS HTML image in UNIX

Reply
N/A
Posts: 1

can't display ODS HTML image in UNIX

I'm trying to insert images in my HTML file using ODS HTML and proc report.  The images will work if I run from PC and place the image files on my PC. If I ran the code from UNIX and access the images file from a unix location,  the image files didn't show on the html file.  The purpose is to generate html file from a stored process and place it in the sas web report.  The stored process needs to be run from a unix server.   I am looking for any recommendation / suggestions to insert images in the stored process report.

SAS Super FREQ
Posts: 8,739

Re: can't display ODS HTML image in UNIX

Hi:

  Usually, in a stored process, you do NOT use BODY= or FILE= option. Usually, you have the special macro %STPBEGIN/%STPEND OR you have BODY=_WEBOUT (in a more advanced invocation).

  I would recommend that you open a track with Tech Support in order to learn the correct syntax for invoking your stored process in Unix. Also, depending what you mean by "web report" (as in a report opened in a web browser, versus a report opened in Web Report Studio), you may find that your CALL DEFINE statements may or may not work in SAS Web Report studio.

  To send a question to Tech Support, go to http://support.sas.com/ and in the left-hand navigation pane, click on the link entitled "Submit a Problem". Alternately, you can go directly to the Tech Support Problem Form here: http://support.sas.com/ctx/supportform/createForm

cynthia

Ask a Question
Discussion stats
  • 1 reply
  • 269 views
  • 0 likes
  • 2 in conversation