The SAS Output Delivery System and reporting techniques

WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

Reply
Occasional Contributor
Posts: 6

WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

I am running regression task on my data. I have more than 8000 data points. Every time I run the program I keep getting this warning. I try to change the code but I still cannot make it work.

Some of my graphs are not displayed because of that.

Can anyone help me how to change the cutoff of 5000 points? 

Grand Advisor
Posts: 9,682

Re: WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

If you are also generating confidence limits I believe that you need to include the limit points in the toal as well, which would be 3 times the number of distinct input values.

If that doesn't work I would see about generating an output dataset with the predicted and confidence limit values as well as use another procedure to plot with.

Also, it would help to post the code that isn't quite working.

Occasional Contributor
Posts: 6

Re: WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

Thank You for your reply. But I am still not able to do it. I am posting the code for my correlation analysis below:


PROC SQL;
    CREATE VIEW WORK.SORTTempTableSorted AS
        SELECT T.Ki, T.M1i, T.M2i, T.Zi, T.Temp, T."DP Temp"n, T.Humidity, T."(To-Ti)"n, T."(To-Ti)*H"n, T."T*DP"n, T."Temp*Humi"n, T."DP*Humi"n, T."DP*(To-Ti)*H"n, T.Ko, T.M1o, T.M2o, T.Zo
    FROM WORK.MODELING as T
;
QUIT;
TITLE;
TITLE1 "Correlation Analysis";
FOOTNOTE;
FOOTNOTE1 "Generated by the SAS System (&_SASSERVERNAME, &SYSSCPL) on %TRIM(%QSYSFUNC(DATE(), NLDATE20.)) at %TRIM(%SYSFUNC(TIME(), TIMEAMPM12.))";
PROC CORR DATA=WORK.SORTTempTableSorted
    PLOTS=(SCATTER MATRIX)
    COV
    PEARSON
    OUTP=WORK.CORPPearsonCorrMODELING(LABEL="Pearson correlations of WORK.MODELING")
    SPEARMAN
    OUTS=WORK.CORSSpearmanCorrMODELING(LABEL="Spearman correlations of WORK.MODELING")
    VARDEF=DF
    RANK
    ;
    VAR Ki M1i M2i Zi;
    WITH Temp "DP Temp"n Humidity "(To-Ti)"n "(To-Ti)*H"n "T*DP"n "Temp*Humi"n "DP*Humi"n "DP*(To-Ti)*H"n Ko M1o M2o Zo;
RUN;

/* -------------------------------------------------------------------
   End of task code.
   ------------------------------------------------------------------- */
RUN; QUIT;
%_eg_conditional_dropds(WORK.SORTTempTableSorted);
TITLE; FOOTNOTE;
ODS GRAPHICS OFF;

And, this is the warning on the LOG page:

WARNING: Scatter plots with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC CORR

         statement to change or override the cutoff.

WARNING: The scatter plot matrix with more than 5000 points has been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC CORR

         statement to change or override the cutoff.

Grand Advisor
Posts: 9,682

Re: WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

It looks like you need to add MAXPOINTS= xxxxx where xxxxx is greater than 5000 to the PLOTS option:

PLOTS=(SCATTER MATRIX MAXPOINTS=10000)

Though I have had a number of instances where the ODS graphics still limit and don't provide output due to internal limits that options don't always override. In that case you may need to go to a separate PROC SGPLOT or possiblly PROC GPLOT to view all of the points.

Occasional Contributor
Posts: 6

Re: WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

Thanks again, it works for some programs but it doesn't work for all the programs.

I will try PROC SGPLOT and GPPLOT

Occasional Contributor
Posts: 6

Re: WARNING: Most ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= ) option in the PROC REG statement to change or override the cutoff.

For my correlation i just used PLOT(MAXPOINTS=NONE) on the next line, so I have two plot statements in the same program.

However, I have lots of independent variables and around 7000 data points for each so its not plotting all the graphs. However, I am including only couple of ind variables at a time to get all the scatter plots.

Thanks.

Post a Question
Discussion Stats
  • 5 replies
  • 8358 views
  • 5 likes
  • 2 in conversation