The SAS Output Delivery System and reporting techniques

UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Reply
Contributor
Posts: 55

UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Working with an application that runs on several servers. The code is tightly controlled with Clearcase. An identical batch SAS program is run on each system being initiated by CRON. The CRON entry for each server uses the -noquotelenmax system option to turn off The Warning 262 error message. This application uses millions of macro variables that are over 262 bytes long so the warning message will generate millions of log messages if not surpressed.

The CRON and SAS program works fine on all but one server. On that one server the Warning 262 messages are generated even after CRON set the -noquotelenmax system option when executing the program.

Anybody know why the option would be ignored on one system and not others. They code is identical. The .profile and proc options are also identical.
SAS Super FREQ
Posts: 8,864

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Hi:
This isn't really an ODS or PROC REPORT/PRINT/TABULATE question. Since you are experiencing issues on a particular server, but not on others, with the same code, this is the kind of problem that should be resolved with Tech Support.

They have access to all different kinds of servers in order to test and duplicate your results. AND, if there is an issue with NOQUOTELENMAX not working on a particular server, then they are the ones that would issue a Note about the behavior for other users who have the same server configuration.

For example, they already have these NOTES about NOQUOTELENMAX:
http://support.sas.com/kb/19/888.html
http://support.sas.com/kb/00/888.html
http://support.sas.com/kb/7/898.html

To open a track with Tech Support, go to this site:
http://support.sas.com/ctx/supportform/createForm

cynthia
Contributor
Posts: 55

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Posted in reply to Cynthia_sas
I found a way to recreate this issue on a test server even though options noquotelenmax is used in the program.

This options noquotelenmax is toggled off after processing that includes the following type of input.

LIBNAME XMLFILE XML "&abc/&file" XMLMAP="&xmlmap";

The XML file does not generate the 262 message but any regular non-XML files that "may" follow that have a macro variable with a size over 262 will generate the error messages.

I'm coding around this by issuing the options noquotelenmax command before each file is processed rather than at program initialization.

Apparently SAS has an "undocumented feature" when using the LIBNAME XML functionality Message was edited by: JMarkW
N/A
Posts: 0

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

sounds like a place where a developer implements the option to switch off the message before generating code that might cause it, but afterwards or at close of the XML libname engine handler, switches the option to the default rather than the prevailing value. So it should be an easy fix. (imho)

PeterC
Contributor
Posts: 55

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Posted in reply to deleted_user
SAS technical support confirmed today that the error exists in version 9.1.3. They said the problem existed on multiple platforms besides Solaris.

Tech support said that the error is fixed in 9.2
N/A
Posts: 0

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

not much left to add to Cynthia's points, except that executing [pre] proc options option= quotelenmax define value ; run ;[/pre]among many details it reveals [pre]Restricted: Your Site Administrator can restrict modification of this option[/pre]
Do you think this may have happened on that special server ?

PeterC
Contributor
Posts: 55

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Posted in reply to deleted_user
When I have proc options run on that server that answer does not return. The userid that I can have it run under is not the same as the one run from CRON.

I'm going to bounce a question about this back to a SAS support contact.

Thanks!
Contributor
Posts: 55

Re: UNIX SAS System Option -noquotelenmax Ignored in Code "Sometimes"

Posted in reply to deleted_user
Unfortunately the result of the options command was:

"Your Site Administrator has not restricted any SAS options."

It looks like that was another dead end.
Ask a Question
Discussion stats
  • 7 replies
  • 315 views
  • 0 likes
  • 3 in conversation