The SAS Output Delivery System and reporting techniques

Turning ODS Results Off

Reply
Frequent Contributor
Posts: 84

Turning ODS Results Off

Is there a way to turn off the SAS Report that automatically is populated on running ODS?

 

I have the following:

 

ods listing close;
ods html close;
goptions device=actximg;
ods excel file="\\NCRFP4\TAF\Traffic Analysis\Major New Analysis Projects\Rebate Analysis\Raw Data by Fee\Amount by Fee.xlsx";
ods excel options(start_at="1,1" sheet_name="TERM" sheet_interval="table" embedded_titles='no');
proc print data=EGTASK.REBATE_RAW_TERM noobs; run;
ods excel options(start_at="1,1" sheet_name="ENR" sheet_interval="table" embedded_titles='no');
proc print data=EGTASK.REBATE_RAW_ENR noobs; run;
ods excel options(start_at="1,1" sheet_name="OVR" sheet_interval="table" embedded_titles='no');
proc print data=EGTASK.REBATE_RAW_OVR noobs; run;
ods excel options(start_at="1,1" sheet_name="NAT" sheet_interval="table" embedded_titles='no');
proc print data=EGTASK.REBATE_RAW_NAT noobs; run;
ods excel options(start_at="1,1" sheet_name="ICOMM" sheet_interval="table" embedded_titles='no');
proc print data=EGTASK.REBATE_RAW_ICOMM noobs; run;
ods excel options(start_at="1,1" sheet_name="DAILY" sheet_interval="table" embedded_titles='no');
proc print data=EGTASK.REBATE_RAW_DAILY noobs; run;
ods excel close;

All runs fine, but I get SAS Report - Output to Excel ouput created in  my EG window. Only the Excel is needed. Is there an option to suppress the report but not the Excel write?  thanks

 

Super User
Posts: 12,994

Re: Turning ODS Results Off

ODS NORESULTS;

 

will prevent sending output to the results window.

Frequent Contributor
Posts: 84

Re: Turning ODS Results Off

thanks...I had tried that. It turns off both the listing report as well as the display of the Excel file on the screen (it is written fine though). I wsa hoping to keep the Excel file as a display item without the SAS Listing Report. Seems like this can't be done.

Esteemed Advisor
Posts: 5,390

Re: Turning ODS Results Off

Try

 

ods listing select none;

.....

ods listing select all;

PG
Ask a Question
Discussion stats
  • 3 replies
  • 227 views
  • 0 likes
  • 3 in conversation