The SAS Output Delivery System and reporting techniques

Opening ODS listing after Closing: ODS LISTING; doesn't work

Accepted Solution Solved
Reply
Contributor
Posts: 26
Accepted Solution

Opening ODS listing after Closing: ODS LISTING; doesn't work

Hi SAS Community,

 

I am using SAS 9.4 and I (accidentially) closed ODS LISTING by doing "ODS _ALL_ CLOSE;" and now I can't get my output back.  I have done "ODS LISTING;" and it doesn't fix it; all proc statements run but nothing shows up in the results pane and nothing appears in the output window.  When I do "ods listing show;" I get this output:

 

2307  ods listing show;
Current LISTING select list is set to default value (ALL).
Current OVERALL select list is: NONE

 

Can anyone else help me?

 

Thanks,
Eric


Accepted Solutions
Solution
‎02-22-2016 10:26 AM
Super User
Posts: 19,171

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

Did you accidently use ODS NORESULTS? Or ODS exclude?

Does the following change anything?

 

ODS RESULTS;
ODS SELECT ALL;
ODS LISTING;
Proc Means data=sashelp.class;run;

 

View solution in original post


All Replies
Super User
Posts: 11,134

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

Default with 9.4 is HTML not Listing.

You may need to provide a PATH to work with that if setting with code

 

ODS HTML <path>;

where path points to a location you can write to.

Or go to the menu Tool>Options>Preferences>Results and see if the HTML box is checked, if not check it.

 

And I HATE all the examples floating around with the _ALL_ Close.

Super User
Posts: 19,171

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

Just a thought, do you have the results window open? You should only need:

 

ods listing;

 

The default in 9.4 is HTML though, which would be:

 

ods html;

Contributor
Posts: 26

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

Sorry, I should have clarified that in this session I set my preferences to revert back to the SAS 9.2 way of display (under Tools/Preferences uncheck "Create HTML", uncheck "Use ODS Graphics" and check "Create Listing".  The only reason I was mucking about with all of this is I was trying to get all output to always show up in the Output window (instead of sometimes showing up in the Results Viewer.)  I must have screwed things up beyond where I can fix them.  One note is that nothing shows up in the Results Window (not Results Viewer, but the Results Window or Panel or whatever it is called) whenever I run a proc.  The log indicates that the proc has run, but like I said, no output shows up.

Solution
‎02-22-2016 10:26 AM
Super User
Posts: 19,171

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

Did you accidently use ODS NORESULTS? Or ODS exclude?

Does the following change anything?

 

ODS RESULTS;
ODS SELECT ALL;
ODS LISTING;
Proc Means data=sashelp.class;run;

 

Contributor
Posts: 26

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

I must have done ODS NORESULTS somehow.  ODS RESULTS fixed it.  I don't know why I couldn't find this solution elsewhere. Thanks so much for the solution, Reeza!

Super User
Posts: 19,171

Re: Opening ODS listing after Closing: ODS LISTING; doesn't work

One of the answers I know, because I've done it Smiley Tongue

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 558 views
  • 2 likes
  • 3 in conversation