The SAS Output Delivery System and reporting techniques

OPTIONS MISSING='' does not work in IMap

Reply
Frequent Contributor
Posts: 97

OPTIONS MISSING='' does not work in IMap

Hello,

I am using OPTIONS MISSING='' for a dataset which has balance.

When used in EG it works when the dataset is opened. the missing values are shown as blanks.

However, when the same dataset is created through an SP which is used in an IMap, the missings are not shown as blanks.

Regards
Sanjay
Frequent Contributor
Posts: 97

Re: OPTIONS MISSING='' does not work in IMap

To make it more clear

SP Code is
OPTIONS missing='';
data wrstemp.a_delete;
length a 8;

a=1234.543;output;
a=.;output;
a=10;output;
run;

This SP creates a dataset in wrstemp.

An Information Map uses this dataset to display the data which is using the above SP in the IMap.

This Imap is then selected in Web Report Studio as data and displayed.

The above code is just an example to describe the issue.
SAS Super FREQ
Posts: 8,740

Re: OPTIONS MISSING='' does not work in IMap

Hi:
This is not an ODS or Base Reporting procedure issue. The MISSING option in Base SAS works to alter the DISPLAYED value of a missing variable value -- such as when you use PROC PRINT, PROC REPORT, PROC MEANS, PROC FREQ, etc. The MISSING option does NOT change the internally stored value of the missing value -- it is the internally stored value that your information map is using.

Your best bet for help with an Information Map and Web Report Studio question is to work with Tech Support. I believe if you had OPTIONS MISSING=' '; (quote space quote) BEFORE a PROC PRINT, then your displayed results in a stored process would show a blank instead of missing. However, I do not believe your existing code will work as you expect.

Tech Support can gather version and configuration information from you and can test a similar stored process in the same enviroment.

cynthia
Super User
Posts: 9,662

Re: OPTIONS MISSING='' does not work in IMap

Do you try to use proc formate ?



Ksharp
Super User
Posts: 9,662

Re: OPTIONS MISSING='' does not work in IMap

Do you try to use proc formate ?



Ksharp
Ask a Question
Discussion stats
  • 4 replies
  • 205 views
  • 0 likes
  • 3 in conversation