The SAS Output Delivery System and reporting techniques

ODS HTML line statement not appearing in output

Accepted Solution Solved
Reply
Contributor
Posts: 53
Accepted Solution

ODS HTML line statement not appearing in output

Hi all,

I'm using proc report with ods HTML to output a sample report.  At each break of the grouped variable (age)  I'd like to write out a line ('TestLine').  The program runs clean but the line never appears.  I inspected the resulting html in a text editor and verified that the text of the added line is not in the file.  Any ideas what I'm missing?

data class;

          set sashelp.class;

run;

ods listing close;

ods html file="c:\temp\test.html";

proc report data=class nowindows;

          column age name;

          define age   / group;

          define name   / display;

          break after age/;

          compute after age;

              line 'TestLine';   

          endcomp;

run;

ods _all_ close;


Accepted Solutions
Solution
‎02-20-2012 09:27 AM
SAS Super FREQ
Posts: 8,868

Re: ODS HTML line statement not appearing in output

Hi:

  Did someone change the STYLES.DEFAULT style template???? I do not observe the same behavior -- see the screenshot -- I tested 2 different styles in SAS 9.3 -- using your code with my TITLE statement added. I would suggest that you open a track with Tech Support.

cynthia


testline.jpg

View solution in original post


All Replies
PROC Star
Posts: 7,492

ODS HTML line statement not appearing in output

Interesting!  When I ran your code the line was there.

SAS Super FREQ
Posts: 8,868

ODS HTML line statement not appearing in output

Hi:

  Are you by any chance using this in a stored process? The SASReport XML that is generated for some client applications of the BI Platform does not render the LINE statement output.

cynthia

Contributor
Posts: 53

ODS HTML line statement not appearing in output

Posted in reply to Cynthia_sas

I open 3 pane SAS, paste in the exact code above and click submitt.  See the attched image as the output I get.  Any idea what might be going on here?  The lines appear perfectly when outputting to PDF and XLS, but nothing for HTML.  Any help would be appreciated.

output.jpg

Solution
‎02-20-2012 09:27 AM
SAS Super FREQ
Posts: 8,868

Re: ODS HTML line statement not appearing in output

Hi:

  Did someone change the STYLES.DEFAULT style template???? I do not observe the same behavior -- see the screenshot -- I tested 2 different styles in SAS 9.3 -- using your code with my TITLE statement added. I would suggest that you open a track with Tech Support.

cynthia


testline.jpg
Contributor
Posts: 53

Re: ODS HTML line statement not appearing in output

Posted in reply to Cynthia_sas

Yeah, that's got to be it.  I tried the same code on a different PC and it worked fine.  Thanks for your help!

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 326 views
  • 0 likes
  • 3 in conversation