The SAS Output Delivery System and reporting techniques

I am having a problem getting my background image to show in RTF output.

Accepted Solution Solved
Reply
Contributor
Posts: 23
Accepted Solution

I am having a problem getting my background image to show in RTF output.

,I am using PROC TEMPLATE to create a style, and include a simple background JPG graphic designed to fill the page. Here's the code:

 

proc template;

define style safetyslides ; parent=Styles.rtf;

style Body from Document / leftmargin=.25in rightmargin= .25in topmargin=.25in bottommargin=24pt

height=8.5in width=11in backgroundimage="C:\backgrounds\background1.jpg";

style systemtitle / just=center foreground=black font_face=arial font_size=24pt font_weight=bold;

style systemfooter / just=right foreground=black font_face=arial font_size=12pt ;

style table / cellpadding=3pt cellspacing=2pt bordercolor=black borderwidth=2pt width=684pt;

style header / background=white foreground=black font_weight=bold font_size=20pt just=center font_face=arial;

style rowheader / font_size=20pt font_face=arial;

style colheader / font_size=20pt foreground=black just=center font_weight=bold font_face=arial;

style data / foreground=black just=left font_face=arial font_size=20pt vjust=bottom;

end;

No matter what I do, the background is still white. I tried scaling the background jpg using MS picture editor to 150dpi (from a SAS Tech Note), but that did not seem to work. Should I try to create the graphic so that it is 8.5x11 to fill the page? I'm at a loss here. I am using RTF, not TAGSETS.RTF as my ODS destination.

Thanks,

Derek


Accepted Solutions
Solution
‎02-22-2013 01:08 PM
Super User
Posts: 12,148

Re: I am having a problem getting my background image to show in RTF output.

Posted in reply to cov_derek

My online documentation, SAS 9.2.3, for BACKGROUNDIMAGE doesn't indicate support for RTF or measured RTF, only markup, PCL and PS destinations.

View solution in original post


All Replies
Solution
‎02-22-2013 01:08 PM
Super User
Posts: 12,148

Re: I am having a problem getting my background image to show in RTF output.

Posted in reply to cov_derek

My online documentation, SAS 9.2.3, for BACKGROUNDIMAGE doesn't indicate support for RTF or measured RTF, only markup, PCL and PS destinations.

Contributor
Posts: 23

Re: I am having a problem getting my background image to show in RTF output.

Posted in reply to cov_derek

Well that would certainly explain it. Guess I would have to add any background to the RTF file in Word.

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 497 views
  • 0 likes
  • 2 in conversation