The SAS Output Delivery System and reporting techniques

Email service not available

Reply
New Contributor
Posts: 4

Email service not available

Hi,

Not sure if this is the right discussion group to ask this but here it goes.  I have tons of programs sending hundreds of emails (.pdfs and .csvs) everyday through our SMTP email server to people across the globe.  I am using Base SAS 9.1.3.  Almost randomly, I am experiencing this "Email Service Not Available" error at times and it seems to be much worse with my users in Europe.  I contacted SAS support and my corporate IT support, but they were useless as the replies were "Email Server problem not my problem" and "SAS problem not my problem".  I am nearly 100% certain it must be a timeout issue in that SAS attempts to hit the email server and gives up after 30 seconds based on my google research.  Anyone have ideas to fix this problem?  I am going to 9.2 in the next month or so.

thanks,

Valued Guide
Posts: 3,208

Re: Email service not available

Would suggest SAS 9.4 if you need secure mail. SAS(R) 9.4 Statements: Reference

For the time-out check SAS-options SAS(R) 9.4 System Options: Reference (emailackwait) and SAS(R) 9.4 Statements: Reference (what's is new)

They promised a 32-bit client version support with their second release 9.4. Soemtimes the last previous version in this 9.3 is already having that undocumented. 

This is all well documented, you have been in the support swamp of "not my problem". 

---->-- ja karman --<-----
New Contributor
Posts: 2

Re: Email service not available

CryoKen- I am having the same issue in Base SAS 9.1.3.  Did you ever figure out what is causing this and if there is a fix ?


Thanks in advance.



New Contributor
Posts: 4

Re: Email service not available

No resolution yet.  It is a hit and miss issue for me and I have not had any issues lately.

Valued Guide
Posts: 3,208

Re: Email service not available

When you have a timeout then there is reason for that as possible:

- temporary too much load on the emailserver

- lines / firewalls slowing down everything,

- intended delays preventing spam,

- virtualization having some effects. etc.

All of them I have seen at some time happening as being a possible cause. root-cause analyses is tedious and a lot of work.

When you have it by its tail you easily again into the "no my problem" attitude.

Only some load analyses at your SAS server is visible and can be more easily seen and analyzed.

If it is worth all the effort ... more easy to find a bypass.

The new emailackwait options at SAS 9.4 is saying there have been more issue with that. It is an update....

---->-- ja karman --<-----
Frequent Contributor
Posts: 117

Re: Email service not available

Sometimes the email sending failed due to the size of files also. Check the size of  files you are sending and prefer to send it in zip files or give the content type in the attachment .

(Can you paste  a sample code which you are using so that we can have a better solution).

for example content_type="application/excel"

                                      ="application/csv"  etc.

New Contributor
Posts: 4

Re: Email service not available

In my case I feel certain it is not a file size issue.  The error happens on the first email of a long sequence of emails and no email exceeds 153k as I am attaching tiny .pdf files.  Each day I mail through SAS hundreds of these files to people around the globe.  It has been at least 1 month since I have had the issue happen again.  I really think the SAS 9.4 fix would solve my problem and if I could rationalize the cash to upgrade based on this need I would.

New Contributor
Posts: 2

Re: Email service not available

I don't think it's a file size issue in my case.  Some of the email I am sending don't have an attachment and they are still failing.  It's random, the programs that are failing run without issues on some days.

This issue started for us around 1 month back.

Per SAS, it's not a SAS issue and it's something to do with SMTP server.  We have been on SAS 9.1.3 for a few years and we never had this issue, and so we can't justify upgrading to SAS 9.3 or 9.4 just to fix this one issue.

Ask a Question
Discussion stats
  • 7 replies
  • 2008 views
  • 0 likes
  • 4 in conversation