The SAS Output Delivery System and reporting techniques

Disable-WARNING: No output destinations active.

Accepted Solution Solved
Reply
Contributor
Posts: 22
Accepted Solution

Disable-WARNING: No output destinations active.

Is there a way to disable this warning?

I have a macro program in which I have PURPOSELY turned-off all destinations and am using old-fashion OUTPUT statements on various PROCs (e.g., UNIVARIATE and SUMMARY) to get the output into datasets that I later summarize via various ODS destinations (in the program in question I'm outputting to the RTF and TAGSETS.EXCELXP destinations) --- and I don't want any output from the PROCs in question otherwise (I've also got 'ods results off' set) ---

--- BUT I don't want the WARNING in the log (I'm actually redirecting the log via PROC PRINTTO), as I want my end users to review the log for "real" errors and warnings --- so I just want to turn of that particular warning, so they aren't distracted by so many of the same (in this case) meaningless warnings.

Is that possible?

TIA


Accepted Solutions
Solution
‎08-03-2011 06:43 AM
SAS Employee
Posts: 6

Disable-WARNING: No output destinations active.

Allen,

  Try:

ods select none;


-- David Kelley, SAS

View solution in original post


All Replies
Super User
Super User
Posts: 6,495

Disable-WARNING: No output destinations active.

Many procs have NOPRINT options.

You could also try re-directing listing to a null device.

* Unix ;

ods listing file='/dev/null' ;

* PC ;

ods listing file='nul:';

Contributor
Posts: 22

Disable-WARNING: No output destinations active.

David,

Worked great, when I used your suggestion INSTEAD of closing all ODS destinations (I assume you intended that).

Thanks-Allen

Contributor
Posts: 22

Disable-WARNING: No output destinations active.

Tom,

I already was using the NOPRINT in the procedures that needed that (e.g, UNIVARIATE), and the other I was using (SUMMARY) doesn't produce 'printed' results. I didn't try your suggestion of routing the LISTING to "null", since in SAS 9.3 the default ouput destination is not LISTING ... and I found David Kelley's later answer to work. Thanks for the suggestion anyway.

Take care-Allen

Occasional Contributor IJU
Occasional Contributor
Posts: 10

Re: Disable-WARNING: No output destinations active.

Hi Tom,

I was looking for a solution to suppress listing, but output HTML. ‘ODS select none’ disables all destinations including HTML.  Your solution with re-directing listing to a null device removes listings only.  I knew how to redirect in DOS batch script: ‘ > nul’, but did not realize that the same syntax can be used in SAS code.  A simple Google search brought me to this discussion.

Thank you very much.

Solution
‎08-03-2011 06:43 AM
SAS Employee
Posts: 6

Disable-WARNING: No output destinations active.

Allen,

  Try:

ods select none;


-- David Kelley, SAS

Frequent Contributor
Posts: 90

Re: Disable-WARNING: No output destinations active.

Can anyone tell me the differance with this code lines below?
My suppervisor instructed me to use the later, but I keep getting the warning discribed in this thread.  -KJ

:

 

 

ods select none;

ods listing close;

 

 

 

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 6004 views
  • 2 likes
  • 5 in conversation