The SAS Output Delivery System and reporting techniques

Accessing zip program remotely

Reply
N/A
Posts: 0

Accessing zip program remotely

Hello,

I am trying to unzip remote zipped files that reside on a windows 2003 server. We are using the freeware 7z program rather than the mainstream winzip.

My problem is that when I try and use an x or %sysexec command remotely to unzip the files, it is causing my SAS session to hang/freeze (with the title "Remote processing in progress").

I have set the appropriate options to maintain control of my SAS session noxwait and xsync but this does not change anything.

In an effort to try and find the problem I have :
1.) Downloaded the software to my local machine and tried the x command with the 7z syntax. It works.
2.) Remote connected to the windows 2003 server and ran the command through a DOS window. It works.

I am therefore stuck. Surely you can access remote programs through remote x commands as you are using the operating system of the server as opposed to your local machine.

Many Thanks.
SAS Super FREQ
Posts: 8,864

Re: Accessing zip program remotely

Posted in reply to deleted_user
Hi:
I believe that the X command can be disabled. This is the case with SAS Enterprise Guide -- EG users usually cannot issue X commands on the server.

Your best bet for help with this question is to contact Tech Support, as they can look at your specific configuration information and your program and give you a definitive answer.

cynthia
N/A
Posts: 0

Re: Accessing zip program remotely

Posted in reply to Cynthia_sas
Hi Cynthia.

I have left a message with the tech guys (via your online form). I can issue standard dos commands like dir etc.

Many thanks,
Super Contributor
Posts: 260

Re: Accessing zip program remotely

Posted in reply to deleted_user
Hi.
What if you connect asynchronously (use CONNECTWAIT=NO in the SIGNON statement) ? That would prevent your SAS session to freeze.

Olivier
N/A
Posts: 1

Re: Accessing zip program remotely

Posted in reply to deleted_user

Hi I am also facing similar issue. I have two user id. With my personal user id it is working. But when it comes service id it is not working. My sas session is getting freeze. Can you please tell me how this issue was resolved when you faced the issue earlier?

Ask a Question
Discussion stats
  • 4 replies
  • 338 views
  • 0 likes
  • 4 in conversation