SAS Office Analytics, SAS Add-In for Microsoft Office, and other integrations

How do you trouble shoot the SAS Add-in for MS Office

Reply
Occasional Contributor
Posts: 7

How do you trouble shoot the SAS Add-in for MS Office

Does anybody have any good tips or documentation on how to trouble shoot the SAS Add-in. I have a client that has in the past openend WRS reports in Excel via the SAS Add. This was using SAS 9.2.

We have recently moved to SAS 9.3 and moved all their files and metadata to a new server. The reports have been tested and everything works as expected in SAS WRS, but when I attempt to open the reports in MS Excel we get the following error.

Capture.GIF

I have been trying to determine where the error is occuring with no luck and I have had very little success in finding and docmentation on the SAS support site that helps. So if anybody has an tips or ideas on where we should be looking that would be a great help.

Cheers

Mark

Community Manager
Posts: 2,607

Re: How do you trouble shoot the SAS Add-in for MS Office

This looks like an question for SAS Technical Support.  They may ask you to enable additional logging, using the steps in this SAS note:

http://support.sas.com/kb/31/217.html

Chris

Occasional Contributor
Posts: 5

Re: How do you trouble shoot the SAS Add-in for MS Office

Hi all,

I've got exactly the same problem. In addition, I cannot enable additional logging (don't have an admin privilages). Does anybody know how to fix this issue?

Thanks in advance!

Cheers

Occasional Contributor
Posts: 7

Re: How do you trouble shoot the SAS Add-in for MS Office

Thanks Chris. I used the suggested technote and it indeed gives you a lot of useful information. So here is an update for those playing at home. We raised a Support Task and did further investigation. The two things that we have come across is that AMO 4.3 does not like Cross tabulation and is noted in the recent Hot Fix G28001 and G30001. We are in the process of downloading this and will test further.

The other factor is group breaks and on this one I can't determine if it is our data or a bug, I'm think it is our data as other reports with group breaks work, but there might be other combinations at play. The work around for the client at the moment that covers both is to export from WRS as an Excel file and them open in Excel. At the moment this is ok as they are just dealing with static reports but in the future we want to look at dynamic reports and this is were AMO will come into it's own.

We are also looking to deploy AMO 5.1 and SAS EG 5.1.

Cheers

Mark.

Super Contributor
Posts: 356

Re: How do you trouble shoot the SAS Add-in for MS Office

What is the version of your AMO?

Occasional Contributor
Posts: 5

Re: How do you trouble shoot the SAS Add-in for MS Office

Hi,

I've got WRS 4.3 and Add-In 4.3 (4.3.0.10196),

Regards

Post a Question
Discussion Stats
  • 5 replies
  • 637 views
  • 4 likes
  • 4 in conversation