SAS Office Analytics, SAS Add-In for Microsoft Office, and other integrations

Hotfix available for SAS Add-In for Microsoft Office 2.1

Reply
SAS Employee
Posts: 33

Hotfix available for SAS Add-In for Microsoft Office 2.1

There is a new hotfix available for the Add-In version 2.1. It addresses a number of customer-reported issues.

The link:
http://ftp.sas.com/techsup/download/hotfix/amo21.html

-Bill
N/A
Posts: 0

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

Bill,

I've just started testing the Add-in with Excel. I've opened a metadata defined data source into a worksheet, made data changes, and attempted to save it back to the server (using SAS - Active Data - Copy to Server).

After applying this hotfix, I can now see the metadata defined library under Summary of Active Data in the "Copy to SAS Server" dialog. But I don't see my defined library when I browse the Save As tab. I can only see default libraries for SASMain (work, sys_mac, sashelp ...).

When I click OK to see what happens I'm getting a SAS Add-in popup stating ' "Copy to Server" failed to initialize', "The data source for this operation could not be opened".

Any ideas?

Thanks - George
SAS Employee
Posts: 33

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

George,

Libraries defined with the META engine (using the default options) and those marked as read-only will not be shown when choosing a place to save data. AMO hides read-only (and META when tracking columns as that makes it read-only as well) libraries for saving purposes.

To address the error message, I don't have a useful answer. Please contact tech support to resolve this issue.

Bill
N/A
Posts: 0

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

Bill,

I've revisited this and decided to reinstall the hotfix. I verified that all components installed successfully. Also, when creating my library in SMC I used the engine BASE and kept all other defaults.

When copying the worksheet data to the SAS server my user defined library is now available on the Copy to SAS Server dialog box as expected.

The process runs but then prompts me with an error box. A snippet from that log shows:

-----------
data XYZ.a2;
set XYZ.a1;
run;

ERROR: You cannot create or delete datasets, views or indexes in this mode. Try the option
METAOUT=DATA. Use Proc Metalib to create metadata for datasets.
-----------

Since I'm mostly running default settings, I'm wondering if I missed something in my setup?

Thanks again,
George
SAS Employee
Posts: 33

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

George,

Go bach into SMC and bring up the properties for your library. On the Options tab, press the "Advanced Options..." button. The first tab, Pre-Assign, has one checkbox, "Library is pre-assigned". By default, library is pre-assigned is unchecked. For your needs, you will want to enable this checkbox turning on pre-assignment for this library.

Pre-assigning libraries defined in metadata will force the underlying engine, in your case BASE, to be used instead of the META engine which renders the data read-only in the Add-In.
N/A
Posts: 0

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

Bill,

Changed the library to pre-assigned, recycled the metadata server (I this a requirement?), but ran into the same error. Tried changing the engine to V9 and pre-assigned, but no luck either.

Is there a central resource for information on using the Add-In, or are SUGI papers and help files the best bet?

George
SAS Employee
Posts: 33

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

George,

I don't think you needed to recycle the metadata server. You will need to recycle your Office application(s) (exit and re-run Excel, Word, PPt or re-connect to the metadata server via SAS->tools->server connections).

I would suggest working with tech support. I've run out of ideas, sorry.
N/A
Posts: 0

Re: Hotfix available for SAS Add-In for Microsoft Office 2.1

Ok, thanks. I'm close...
Post a Question
Discussion Stats
  • 7 replies
  • 368 views
  • 0 likes
  • 2 in conversation