tagset rejecting alignment

Reply
Occasional Contributor
Posts: 14

tagset rejecting alignment

I am having a problem with alignment of titles using excelxp.

There are titles for this set of sheets. The first table, title1 is aligned left, but the next two titles, and all titles for the remaining sheets are aligned properly.

This is my code. Has anyone run into this problem?

%macro tables_safety (title1, title2, title3, sheet, data, box, source, TOC1, TOC2);

ods tagsets.excelxp options

    (

        center_horizontal = 'yes'

        center_vertical = 'yes'

        embedded_titles="yes"

        embedded_titles_once="yes"

        embedded_footnotes="yes"

        embedded_footnotes_once="yes"

        sheet_name= &sheet

               

        width_points='1'

        width_fudge='1'

        absolute_column_width = '250,30,30,30,30,30,30,30,30,30,30,30,30,30,30,30'

        row_heights = '50,17,20,15,12,10'

    );                               

   

    title1      justify=center bold color=black font=arial height=10pt &title1;

    title2      justify=center bold color=black font=arial height=10pt &title2;

    title3      justify=center bold color=black font=arial height=10pt &title3;

    footnote1 justify=left   bold color=black font=arial height=8pt &source;

    footnote2 justify=center color=grey font= arial height=6pt 'Biomedical Statistical Consulting';

    footnote3 justify=center color=grey font= arial height=6pt 'Since 1986 Providing Quality in Design, Implementation, and Presentation';

Occasional Contributor
Posts: 14

Re: tagset rejecting alignment

If this helps, I tried commenting out my previous macro which also creates a table, and title was correctly aligned.

the previous macro is

macro tables_safety (title1, title2, title3, sheet, data, box, source, TOC1, TOC2);

ods tagsets.excelxp options

    (

        center_horizontal = 'yes'

        center_vertical = 'yes'

        embedded_titles="yes"

        embedded_titles_once="yes"

        embedded_footnotes="yes"

        embedded_footnotes_once="yes"

        sheet_name= &sheet

               

        width_points='1'

        width_fudge='1'

        absolute_column_width = '250,30,30,30,30,30,30,30,30,30,30,30,30,30,30,30'

        row_heights = '50,17,20,15,12,10'

    );                               

   

    title1      justify=center bold color=black font=arial height=10pt &title1;

    title2      justify=center bold color=black font=arial height=10pt &title2;

    title3      justify=center bold color=black font=arial height=10pt &title3;

    footnote1 justify=left   bold color=black font=arial height=8pt &source;

    footnote2 justify=center color=grey font= arial height=6pt 'Biomedical Statistical Consulting';

    footnote3 justify=center color=grey font= arial height=6pt 'Since 1986 Providing Quality in Design, Implementation, and Presentation';

proc tabulate data= &data S=[just=c vjust=m]

    contents =&TOC1;

    class site group_table / preloadfmt ;

    class codeae1 symptom1 / preloadfmt  missing;

    class onset_day /  preloadfmt missing;

   

    table symptom1='Operative Site'  codeae1='Non-Operative Site'  all='Totals' * [style=[background=grey]],

           

            onset_day=' '* (group_table=' '*n=' ' )

            all='Totals' * [style=[background=grey]] * (group_table=' ' *n=' ' )

            / misstext='0'  printmiss box=&box contents=&TOC2 ; /* misstext fills in missing with zeros

                                                                    printmiss includes both groups even if there are not observations

                                                                        box adds border

                                                                           contents fills the TOC page*/

   

run;

Super User
Posts: 3,115

Re: tagset rejecting alignment

Are you using the latest version of the Excelxp tagset - V1.130? The version used is reported in your SAS log.

If you are not using the latest version then you can download it from here:

http://support.sas.com/rnd/base/ods/odsmarkup/

I've had a number of issues cured by going to the latest version including ones related to titles and footnotes.

Occasional Contributor
Posts: 14

Re: tagset rejecting alignment

thank you for this. I was not using the newest version, I downloaded and used %include newest_version.

this did not solve the problem, but, this is this still good to know.

Ask a Question
Discussion stats
  • 3 replies
  • 232 views
  • 3 likes
  • 2 in conversation