sas option -UTILLOC on Linux Server

Reply
Contributor
Posts: 38

sas option -UTILLOC on Linux Server

Hallo,

I am working using EG on server. I specified the following option in file "sasv9_local.cfg" but it does not work. EG is unable to connect with server after specifying this option.

-WORK /data/sas/work

-UTILLOC= (WORK,/data/saswork_add/worku1, /data/saswork_add/worku2, /data/saswork_add/worku3);

thanks in advance for suggestions.

Regards

Ehsan

Super User
Posts: 13,563

Re: sas option -UTILLOC on Linux Server

Posted in reply to ehsanmath

Just to check:

Tried without WORK in the list?

Do the folders saswork_add/worku1  /worku2 and /worku3 already exist?

Permission to read, write and delete in those folders?

Case sensitivity in the folder names?

Contributor
Posts: 38

Re: sas option -UTILLOC on Linux Server

I already Tried without WORK  but does not work.

yes, the folders "saswork_add/worku1  /worku2 and /worku3" already exist

Permission is to read write and delete is also there.

Case sensitivity is also not an issue i checked it once again.

Trusted Advisor
Posts: 3,215

Re: sas option -UTILLOC on Linux Server

Posted in reply to ehsanmath

There are usermod files for all kind of configuration tasks. Did you see the notices "do not modify...?"

As you are working in Unix you can test all those changes by using X11 directly starting the scritp. Less info is coming using Eguide (parallel code submission)

You are often dependent on storagemanagers delivering segregated services/paths. When this is not the case the benefits are not reachable.

  SAS(R) 9.3 System Options: Reference, Second Edition  utilloc is default to work. specifyin an other series would be 

UTILLOC= ('/data/saswork_add/worku1', '/data/saswork_add/worku2', '/data/saswork_add/worku3');      /* no work!  it is no location */

I prefer quotes although not being necessary having no spaces.

With 9.4 you could use that text file mentioning the method. 

SAS(R) 9.4 System Options: Reference, Third Edition

---->-- ja karman --<-----
Super User
Posts: 10,259

Re: sas option -UTILLOC on Linux Server

Posted in reply to ehsanmath

Try omitting WORK and the commas.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Contributor
Posts: 38

Re: sas option -UTILLOC on Linux Server

Posted in reply to ehsanmath

Hallo once again,

I tried all the above suggestions but the problem still resists. Any more Ideas that I can try ?

Super User
Posts: 10,259

Re: sas option -UTILLOC on Linux Server

Posted in reply to ehsanmath

The best option will be to try to start SAS from the commandline on the server and see what happens.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Ask a Question
Discussion stats
  • 6 replies
  • 602 views
  • 0 likes
  • 4 in conversation