sas import and LRECL=

Reply
Super Contributor
Posts: 371

sas import and LRECL=

Hello,

I observe that,

When you use "click on button import in sas  EG " to import  a .txt file.

  you will import the file and you will get the correct value,  when you look at the "sas log" of the import, we can observe in the file log

> LRECL=265, but the logical length to use for reading is more than 500.

Why sas EG makes a correct importation, but does not show in the log the right value of LRECL(here=500), but in the log, we see LRECL=265  ?

Occasional Contributor
Posts: 13

Re: sas import and LRECL=

Hi,

I believe you may have the 'Generalize this import step to run outside of Enterprise Guide' option set on the 4 page of the import data task wizard.  By default, this sets a maximum record length of 256.  This should be affecting the output of the import task though, causing a truncation of records.

Regards

Respected Advisor
Posts: 3,837

Re: sas import and LRECL=

In newer EG version the default appears to be set to 32767 - but you can of course always change it to the value you need.

Capture.PNG

Ask a Question
Discussion stats
  • 2 replies
  • 230 views
  • 0 likes
  • 3 in conversation