re: sas mail message

Reply
Regular Contributor
Posts: 229

re: sas mail message

Hi...I am trying to send an e-mail from SAS that has an attachment. When I run the SAS Program, I get the following message that pops up:

A program is trying to automatically send e-mail on your behalf. If this is unexpected, click Deny and verify your antivirus software is up-to-date.

Once I click Allow, the e-mail is sent and everything works fine. Is there anyway to prevent or disable this message from popping up since I would like to have this program run at specified time of the day when I might be able to acknowledge and Click the Allow button.

I have checked with out IT department and all outgoing e-mails are sent with SMTP.

Thanks in Advance.

Super Contributor
Posts: 578

Re: re: sas mail message

How is your smtp server defined for SAS?  Is it using your local mail client or is it sending to a gateway elsewhere on your network?  You might be able to configured your local email client to allow it.

Regular Contributor
Posts: 229

Re: re: sas mail message

Hi DBailey,

I ran the PROC OPTIONS GROUP-EMAIL; the EMAILHOST=LOCALHOST

PROC Star
Posts: 1,322

Re: re: sas mail message

In recent versions of Outlook, I think it pops up that dialog box for you as some sort of "your computer might have been turned into a spam-bot" warning.  WHich annoyingly kills the ability to automate emails....

There are some little apps like http://www.contextmagic.com/express-clickyes/free-version.htm which are supposed to disable this outlook "feature".  I haven't tried any, as all of my automated emails come from our linux server, which happily knows nothing of Outook (or Excel!)

Ask a Question
Discussion stats
  • 3 replies
  • 187 views
  • 0 likes
  • 3 in conversation