option MEMSIZE=2147483648;

Reply
Super Contributor
Posts: 303

option MEMSIZE=2147483648;

please what is wrong with this, having memory problem; option MEMSIZE=2147483648;

Super User
Posts: 7,857

Re: option MEMSIZE=2147483648;

Posted in reply to desireatem

memsize needs to be set from the commandline or in the configuration file, usually sasv9.cfg

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Super Contributor
Posts: 303

Re: option MEMSIZE=2147483648;

Posted in reply to KurtBremser

Hey, thanks very much  could you show me an example?

Super User
Posts: 7,857

Re: option MEMSIZE=2147483648;

Posted in reply to desireatem

Simply add -memsize=number on the SAS invocation command line.

Documentation can be found by googling "SAS memsize option";

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Super Contributor
Posts: 303

Re: option MEMSIZE=2147483648;

Posted in reply to KurtBremser

ANSWERED THANKS

SAS Super FREQ
Posts: 3,755

Re: option MEMSIZE=2147483648;

Posted in reply to desireatem

BTW, you can use "G" as an abbreviation for gigabytes, as in

-memsize=2G

Ask a Question
Discussion stats
  • 5 replies
  • 439 views
  • 2 likes
  • 3 in conversation