infile 'red x' with no error in log

Accepted Solution Solved
Reply
Valued Guide
Posts: 860
Accepted Solution

infile 'red x' with no error in log

Hello,

I have two files that I'm pulling into sas, the variables are the same but the formats and lengths are different.  I made a few changes to the code to lengthen the formats of any variable that was being truncated and changed one numeric character to variable.  Now when I run the code it looks like everything is loaded correctly if I look at the log, I can open the dataset within sas and use it as desired.  The issue is in the project tree there is a red x over the item as if it failed.  I have never seen this and don't understand why that x would show up without an error in the log.

Any insight will be appreciated,

Thanks in advance.


Accepted Solutions
Solution
‎10-25-2012 09:27 AM
Super User
Super User
Posts: 7,039

Re: infile 'red x' with no error in log

Posted in reply to Steelers_In_DC

What tool are you using? Enterprise Guide?

From my experience with other systems with linkages between steps I have used in the past your issue sounds like it might be that your program is not producing the result that the project flow is expecting.  For example the project flow expects step A to produce dataset A but the SAS program actually produces B.  So the SAS log for creating B is fine with no errors, but the project flow is broken because A did NOT get created.

View solution in original post


All Replies
Solution
‎10-25-2012 09:27 AM
Super User
Super User
Posts: 7,039

Re: infile 'red x' with no error in log

Posted in reply to Steelers_In_DC

What tool are you using? Enterprise Guide?

From my experience with other systems with linkages between steps I have used in the past your issue sounds like it might be that your program is not producing the result that the project flow is expecting.  For example the project flow expects step A to produce dataset A but the SAS program actually produces B.  So the SAS log for creating B is fine with no errors, but the project flow is broken because A did NOT get created.

Valued Guide
Posts: 860

Re: infile 'red x' with no error in log

I am using Enterprise Guide, the changes I made were minimal and I didn't expect them to change anything that I didn't intend.  After a few preliminary checks it looks like the data is complete.  I'll be going through many additional checks through the next few days to confirm.

Thank you for your feedback, that is very helpful.

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 354 views
  • 0 likes
  • 2 in conversation