X copy command issue

Accepted Solution Solved
Reply
Contributor
Posts: 41
Accepted Solution

X copy command issue

Hi,

I tried to copy data from one location to another location in same server but I'm getting error and warning messages pls advise me how to copy the data.

see below codes i have tried and  see below errors.

---------------------------------------------------------------------------------------------------------------------------------------------

X ‘copy “N:\PFS\acaodact_sort_201312.sas7bdat”  “K:\UOBT\03_Development\01_Backup” ‘;

------------------------------------------------------------------------------------------------------------------------------------------

systask command "copy N:\PFS\acaodact_sort_201312.sas K:\UOBT\03_Development\01_Backup" wait status=copyfl;

_______________________________________________________________________________-

X "dir N:\PFS\acaodact_sort_201312 > K:\UOBT\03_Development\01_Backup";

----------------------------------------------------------------------------------------------------------------------

NOTE: Procedures may not support all options or statements for all devices. For details, see the

      documentation for each procedure.

10         GOPTIONS XPIXELS=0 YPIXELS=0;

11         FILENAME EGSR TEMP;

12         ODS tagsets.sasreport12(ID=EGSR) FILE=EGSR STYLE=Analysis

12       ! STYLESHEET=(URL="file:///C:/Program%20Files/SAS/EnterpriseGuide/4.3/Styles/Analysis.css")

12       ! NOGTITLE NOGFOOTNOTE GPATH=&sasworklocation ENCODING=UTF8 options(rolap="on");

NOTE: Writing TAGSETS.SASREPORT12(EGSR) Body file: EGSR

-----------------------------------------------------------------------------------------------------------------------

ERROR: Insufficient authorization to access SYSTASK COMMAND.

------------------------------------------------------------------------------------------------------------------------

ERROR: Shell escape is not valid in this SAS session.


Accepted Solutions
Solution
‎02-06-2014 03:35 AM
Occasional Contributor
Posts: 15

Re: X copy command issue

Hi,

You may need to check with your sas-admin if xcmd is allowed in the settings of the stored process server definition.

Regards,

Ton

View solution in original post


All Replies
Solution
‎02-06-2014 03:35 AM
Occasional Contributor
Posts: 15

Re: X copy command issue

Hi,

You may need to check with your sas-admin if xcmd is allowed in the settings of the stored process server definition.

Regards,

Ton

Contributor
Posts: 41

Re: X copy command issue

Thanks Ton,

I will check with admin and I also found some info in SAS portal. below link is explained about this issue.

http://support.sas.com/kb/41/058.html

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 202 views
  • 0 likes
  • 2 in conversation