What can I use to open version 6 datasets?

Accepted Solution Solved
Reply
New Contributor
Posts: 2
Accepted Solution

What can I use to open version 6 datasets?

We have inherited a number of SAS datasets that were created in version 6 (I assume as they have .sd2 as the extension).  We are not currently a SAS shop, so we would like to be able to open them with the universal viewer, but this fails.  Is there anything out there that can open these, shy of the complete SAS package


Accepted Solutions
Solution
‎04-26-2013 01:55 PM
Super User
Super User
Posts: 7,074

Re: What can I use to open version 6 datasets?

Did you try the older SAS System Viewer?  You can still download the final version (9.1) from the SAS website.  It should be able to open .sd2 files.

View solution in original post


All Replies
Solution
‎04-26-2013 01:55 PM
Super User
Super User
Posts: 7,074

Re: What can I use to open version 6 datasets?

Did you try the older SAS System Viewer?  You can still download the final version (9.1) from the SAS website.  It should be able to open .sd2 files.

New Contributor
Posts: 2

Re: What can I use to open version 6 datasets?

Well, that was easy.  Thank you very much.  We're back in business.

Super User
Posts: 10,041

Re: What can I use to open version 6 datasets?

Or you can use proc immgrate to immgrate your old dataset to your current version dataset.

Super User
Posts: 11,343

Re: What can I use to open version 6 datasets?

And if they exist in a folder with only V6 files a libname statement should automatically treat the library as needing the V6 engine, otherwise specify the V6 engine on a libname statement.

libname mylib v6 'v6-SAS-library';

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 278 views
  • 0 likes
  • 4 in conversation