Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

Reply
Occasional Contributor
Posts: 10

Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

I am a student and I have just installed SAS on my computer. I have been getting errors when I try to open a SAS file. I have found an error note which seems related to my problem:

Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

The following error message may occur when running SAS with the wrong

umask setting for the user's WORK directory:

ERROR: User does not have appropriate authorization level for library

WORK.

FATAL: Unable to initialize the options subsystem.

(SASXKINI): PHASE 3 KERNEL INITIALIZATION FAILED.

UNABLE TO INITIALIZE THE SAS KERNEL

This error occurs because the umask settings for ROOT and the user do

not match. By default, ROOT has a umask setting of 022 for all

directories. If a user does not have at least group write authority they

will not be able to write output to the WORK directories.

To circumvent this problem, make sure that the userid also has a umask

of 022 or another setting that includes write authority for the group

However, I do not understand what I am supposed to do now. Can someone please give a step by step guide on fixing this problem?

Super User
Posts: 11,343

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

Is this the University Edition? If so and you're running on a Windows platform the virtual machine settings may be the issue.

If that is not the exact error you are receiving then post exact error text and what you did to get the message. Which method were you using to open a file and what type of file? Program code, process, command line, point and click?

Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

I think I may be running the University edition as I did receive it from my university. I am not sure what virtual machine settings are. I am trying to open a .sas7bdat file. The message is

ERROR: User does not have appropriate authorization level for library WORK.

ERROR: Path: C:\Users\Kevin\AppData\Local\Temp\SAS Temporary

ERROR: Files\_TD5484_KEVIN-PC_.

NOTE: Unable to initialize the options subsystem.

ERROR: (SASXKINI): PHASE 3 KERNEL INITIALIZATION FAILED.

ERROR: Unable to initialize the SAS kernel.

Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

I think I am using the University Edition. I am not sure what the virtual machine settings are. I am trying to open a .sas7bdat file. The message I am getting is:

ERROR: User does not have appropriate authorization level for library WORK.

ERROR: Path: C:\Users\Kevin\AppData\Local\Temp\SAS Temporary

ERROR: Files\_TD5512_KEVIN-PC_.

NOTE: Unable to initialize the options subsystem.

ERROR: (SASXKINI): PHASE 3 KERNEL INITIALIZATION FAILED.

ERROR: Unable to initialize the SAS kernel.

Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

Also, I can open SAS Enterprise Guide fine, but the error occurs when I try to open SAS 9.4.

SAS Super FREQ
Posts: 8,868

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

Hi:

  If you have Enterprise Guide, it is unlikely that you are using the SAS University Edition. The University Edition is SAS, inside a Virtual Machine, the Virtual Machine is accessed thru either VMware Player or Oracle Virtual Box. So if you look on your Start Menu, do you have Start -->All Programs--> SAS --> SAS 9.4 and Start--> All Programs --> SAS --> SAS Enterprise Guide as choices on the Start menu? If so, you are NOT running SAS University Edition.

  If you obtained SAS from your school, they could have given you a site to download from, they could have given you the DVD or they could have given you an install depot. If your school has a help desk or IT department who gave you install instructions, you might want to work with them or you might want to open a track with SAS Tech Support. Until you resolve the write access ERROR message you won't be able to use SAS. EG will probably work when you open it, but then fail when you try to submit any code because EG is only a "front end" that sends your code to SAS for execution.

cynthia

Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

Could someone give me a step by step instructions on what this means?:

This error occurs because the umask settings for ROOT and the user do

not match. By default, ROOT has a umask setting of 022 for all

directories. If a user does not have at least group write authority they

will not be able to write output to the WORK directories.

To circumvent this problem, make sure that the userid also has a umask

of 022 or another setting that includes write authority for the group

Super User
Posts: 3,260

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

The usage note 4440 is only relevant to SAS running on Unix operating systems. The evidence you have provided suggests that you are running SAS on Windows where there is no such thing as a ROOT user or UMASK.

Are you just running SAS on your PC or if you are using EG does it connect to SAS on your PC or a remote SAS server?

Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

I am not entirely sure what you are saying. From what I can tell, SAS 9.4 and SAS Enterprise Guide are separate programs on my computer. I also other SAS programs such as SAS Deployment Manager, IML Studio etc. in the SAS folder.

Trusted Advisor
Posts: 3,215

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

The message 4440 on Unix is an indication that something was done wrong at the installation. That note is a terrible wrong description on what is going on, it is in error.  

The root-cause is a wrong defined sas-work directory. As that one is defined in the SAS config-file that one must be taken into consideration.

The requirement is that anybody should be able to create (write delete anything) in that location is the temporary area /tmp or %tmp% some oldies will recognize.

Unix:
The /tmp is the default shared directory anybody can use on A Unix system, only for small temporary data. For SAS it is far too small. Another or multiple like this have to be defnied. This is going into technical details often being the problematic one to accomplish as SAS is that diificult not being an notepad application.

It can be any acceptable name for Unix-admins like /var/local/sas/tmp at that point the filesystem is set with spave and autorisation. The best chmod setting is 3777  (four digits!) as that is having /tmp also.  The owner can be root (or "sassrv") the group eg "sas" or sas at a higer level so the "others" can have a different meaning.

That 3 is indicating:

a/ sgid  That has the meaning  of the group as set a the directory will be inherited by subdirectories not the primary group.
b/ sticky-bit That has the meaning (only at directories) of deleting is only possible by the owner of the file or by the owner of the directory
The last 7 (others rwx) is only allowed in combination with that first "3".     

That umask is a setting new files/dirs will get by a running process. That note 4440 is humbug.    

Windows:
That %tmp% was well known in the era of DOS 2.1 for a shared but single user system.   It cannot be used in a multiuser system having the issues of unwanted shared temporary data. So they moved it to"%temp%".  You can type that %temp% in your (win)explorer as you can type %appdata%".

1- Please type %temp% and note what you see. That should be "C:\Users\Kevin\AppData\Local\Temp\" Your ID you used with Windows should be "Kevin". When not than you have your issue.
2.1- Using EGuide with the local connection you are using SAS on you desktop. It is the continuation of 1/
2.2- Using Eguide with a server profile than there is a Windows Server somewhere. That one should know you too. (that is another challenge).

You did try to open the sas7bdat file?  Please do not work that way. It is trusting the file-association to start some program on you desktop that will open the file.
In this case Eguide cannot be associated to open the file it is SAS-Base. At least you got a correct message SAS-Base on your desktop has started but is installed wrong.
This could happen when Kevin did give you a modified sas-config with his local/temp hard coded. It will work for Kevin not for you.


  

---->-- ja karman --<-----
Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

I have typed in %temp% and I have gotten "C:\Users\Kevin\AppData\Local\Temp". I am not sure what you mean by instructions 2.1 and 2.2. I am Kevin and I have not installed SAS on any other computer. I received a license file from my university.

Super User
Posts: 7,857

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

Since it's verified that you run your SAS on Windows, this note might be more helpful:

6653 - "Error: User does not have appropriate authorization for library WORK"error message appears a...

First, I would make sure that "C:\Users\Kevin\AppData\Local\Temp\SAS Temporary Files" actually exists, and that you can create a simple file there (to test the permissions). Just create a text file in notepad and try to save it in the "SAS Temporary Files" folder.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Regular Learner
Posts: 1

SOLVED: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

[ Edited ]
Posted in reply to KurtBremser

I experimented exactly the same problem as Kevin.  

The problem appear after re-installation of SAS 9.4...I had experimented problems on double click for .sas files when intalling sas viewer, I un-install everything and re-intall only SAS 9.4 and then the problem appear.

I follow the recomendations

1. I went to temp typing %temp% in "file explorer"

2. Right click --> on temp folder --> security --> Edit permissions.  I gained permissions for my user (see windows tutorials anywhere)

3. I open "SAS Temporary Files" under temp and I try to create a txt file, just to check that I effectively gained permissions.  A window message appear "Click continue to gain permanent permission on this folder"....I click continue and then the .txt file was created.  After that the problem was solved !!!

Thank you !!!

Trusted Advisor
Posts: 3,215

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

The difference between 2.1 and 2.2 is whether you would have:

2.1  SAS-base on the Desk-top with Eguide .       We can accept now this is your situation 

2.2  SAS-base running on a server  with Eguide

What is strange is that your are getting an error with 2 lines for 1 single location

you could try to find the config.sas in the SASHOME below then `progam files (x86)'' And verfiy that SASWORK setting. 
It makes no sense  that setting has got broken up.  "C:\Users\Kevin\AppData\Local\Temp". The rest of "SAS Temporary Files\" (it is one string) is in that config-file.

     ERROR: Path: C:\Users\Kevin\AppData\Local\Temp\SAS Temporary

     ERROR: Files\_TD5484_KEVIN-PC_.

That number 5484 is a random number (_TD_process-id)  followed by machine-id (KEVIN_PC shared work machines servers)

As you got the license-file you did the installation on your machine yourself,

What Windows Version? What SAS version?
Can you find SAS-base to start (should give that error)? and can you find that sas config line about sas-work? (what does it say?)

For the university edition SAS is redirecting first-line support to your university (I believe so).

---->-- ja karman --<-----
Occasional Contributor
Posts: 10

Re: Usage Note 4440: Error: User does not have appropriate authorization level for library WORK

I've actually solved the problem. For some reason, I did not have permission to access the folder even though I am the administrator of the computer.

Ask a Question
Discussion stats
  • 24 replies
  • 1593 views
  • 14 likes
  • 9 in conversation