The Stored Process-API failed to save Stored Process Metadata

Reply
Super User
Posts: 10,209

The Stored Process-API failed to save Stored Process Metadata

I get this when trying to modify an existing STP. The additional message says

"AddMetadata of TextStore is missing required property Name."

A google search and a search in the SAS KB revealed no matching results for this specific problem.

 

Do I have to recreate the STP, or is there something that can be done on the already stored entry?

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
PROC Star
Posts: 1,456

Re: The Stored Process-API failed to save Stored Process Metadata

Posted in reply to KurtBremser

Hmm, only hit I got from google was this post from you last year with same title, where I already failed to help you. : )

 

https://communities.sas.com/t5/SAS-Stored-Processes/The-stored-process-api-failed-to-save-stored-pro...

Valued Guide
Posts: 591

Re: The Stored Process-API failed to save Stored Process Metadata

Posted in reply to KurtBremser

I wonder if the metadata has become corrupted - can you create a simple "Hello World" STP to check that?

Super User
Posts: 10,209

Re: The Stored Process-API failed to save Stored Process Metadata

Posted in reply to ChrisBrooks

Hi @ChrisBrooks, it seems to be related to the Enterprise Guide version. Modifying the STP in EG 7.1 works perfectly well, while 4.3 coughs up; The backend for this specific STP is our older 9.2 server. Other STPs on the same server pose no problem.

Even after the modifcation in 7.1, the STP is unsave-able in 4.3, although the STP was initially created with 4.3.

Strange, but I will try to upgrade the end-user to EG 7.1.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Valued Guide
Posts: 591

Re: The Stored Process-API failed to save Stored Process Metadata

Posted in reply to KurtBremser

@KurtBremser yes 4.3 is pretty ancient although I'm slightly surprised it didn't work. I mostly just use Enterprise Guide to create the STP initially and then do all the coding in DM, UtraEdit or whatever editing tool is available and then upload the edited source to the server. If I need to change the metadata I use Management Console but that may not always be available to developers depending on site policy.

Super User
Posts: 10,209

Re: The Stored Process-API failed to save Stored Process Metadata

Posted in reply to ChrisBrooks

Well, it's only one STP that is affected. Something must have happened that "corrupted" its metadata in a way that 4.3 can't handle. Overall, 4.3 is working fine, even with 9.4 as backend (although I haven't tested the STP creation in that combination yet).

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Ask a Question
Discussion stats
  • 5 replies
  • 156 views
  • 0 likes
  • 3 in conversation