SMTP Setup using Gmail

Reply
Occasional Contributor
Posts: 10

SMTP Setup using Gmail


Hi friends,

I am trying to setup sending Email alerts through my SAS System and trying to setup the SMTP server using the GMAIL. I already tried out many things but nothing is working out for me. There is a usage note from SAS 53215 - How to set up your SAS® installation to use Secure SMTP via Gmail .I tried that but the setting doesnt worked for me. If I set

-emailhost (“smtp.gmail.com” STARTTLS id=gmail-login-ID pw=gmail-password auth=LOGIN port=587); my Metadata server doesn't start at all. Any one tried it actually and successful in sending emails?

Regards,

Shatrughan

Super User
Posts: 10,214

Re: SMTP Setup using Gmail

Posted in reply to shatrughan

What does the Metadata server log say? And do you get an error message when you try to start the metadata server from the commandline?

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Occasional Contributor
Posts: 10

Re: SMTP Setup using Gmail

Posted in reply to KurtBremser

Hi Kurt,

  

Metadata log doesn’t say anything on this issue. Just fails to
start. My system is Windows. So when I start the service, it fails. It happens
when I have anything other than SMTP host in –emailhost. My setting under
MetadataServer/sasv9.cfg:

  

With SSL:

  -emailsys smtp

  -emailhost "smtp.gmail.com"

  -emailport 465

  -emailauthprotocol login

  -emailid "xxxxxxxxx"

  -emailpw "xxxxxxxxx"

Email error 1.png

I even tried with MAPI like below:

-emailsys mapi

-emaildlg native

-emailhost "smtp.gmail.com"

-emailport 587

-noemailfrom

-emailauthprotocol login

-emailid "xxxxxxxxx"

-emailpw "xxxxxxxxx"

Email error 2.png

Regards,

Shatrughan


Super User
Posts: 10,214

Re: SMTP Setup using Gmail

Posted in reply to shatrughan

Hmm.

When googling for "error 530 5.7.1 client was not authenticated" I get a lot of pages which make me suggest that you do not have a problem with gmail, but with the settings of Microsoft Exchange. Since I run my SAS on AIX and use the AIX sendmail as MTA, I won't be able to help you much with this.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
How to convert datasets to data steps
How to post code
Ask a Question
Discussion stats
  • 3 replies
  • 857 views
  • 0 likes
  • 2 in conversation