SAS Data set Compatibility issue

Reply
Contributor
Posts: 66

SAS Data set Compatibility issue

Is there an easy fix to make the data sets created by SAS 9.4   compatible(readable) to SAS 9.1?

Any help would be highly appreciated.

Thanks!

Super User
Super User
Posts: 7,430

Re: SAS Data set Compatibility issue

Datasets should be compatible with any version of 9.x.  The only time I have come across any problems is when datasets are created on another operating system, then you might consider the use of proc cimport/cport.

Super User
Posts: 9,691

Re: SAS Data set Compatibility issue

Not sure if it could work.

Check proc cport  and proc immigrate

proc copy noclone ;

Super User
Posts: 5,260

Re: SAS Data set Compatibility issue

What's you r issue? Did you receive any errors, or do you get unexpected results?

Consider upgrading SAS version in target environment, 9.1 is quite old, and not fully supported by SAS (for instance, 9.1.3 is not supported on Win 7 or higher). Upgrading is included in your license.

Data never sleeps
PROC Star
Posts: 7,366

Re: SAS Data set Compatibility issue

You could try setting the options described in the following thread:

http://listserv.uga.edu/cgi-bin/wa?A2=ind1311b&L=sas-l&D=0&P=17479

Ask a Question
Discussion stats
  • 4 replies
  • 442 views
  • 0 likes
  • 5 in conversation