Question about SAS error

Reply
New Contributor
Posts: 2

Question about SAS error

I have a SAS question, it's been bothering me for a long time. It would be greatly appreciated if any of you could provide me with some help on this.

Some times when I run the code, SAS gives me the following error:

ERROR: Permanent copy of file WORK.UTDATA.UTILITY was deleted.

For example this error occurred when I ran PROC MIXED (and has happened to me before with some other commands). There is no problem with my code, because SAS gave me the correct answer on the first trial. However when I ran the same code again, SAS gave me the error stated above. And I was not able to get SAS outputs because of the error.


I tried closing SAS, reopen SAS, rerun the code, but failed again with new error message:

ERROR: Utility file I/O.

ERROR: Open of file WORK.UTDATA.UTILITY for UPDATE failed; another copy of the file is open for OUTPUT.


But I don't have another copy of the file open for output apparently. After repeating the process about 10 times and failed 10 times, SAS suddenly gave me correct answer(with no ERROR) on the 11th trial. However the same ERROR soon came back.


I already tried reinstall SAS9.3 according to installation instruction, but this doesn't help.

I looked everywhere, but can't seem to find find the solution to this issue. Any help would be greatly appreciated.

Shiyi

Super User
Posts: 17,868

Re: Question about SAS error

That sounds like a tech support question to me.

There is a very small link at the bottom of the page to open a track with tech support.

New Contributor
Posts: 2

Re: Question about SAS error

Thanks!! I already submitted a problem report.

But if anyone who reads the thread and knows the answer, please let me know. Thanks a lot!

Ask a Question
Discussion stats
  • 2 replies
  • 437 views
  • 0 likes
  • 2 in conversation