Problem with SAS.UV.Transport dll

Reply
Learner
Posts: 1

Problem with SAS.UV.Transport dll

Hi,

 

I have installed SAS universal viewer and copied dll's from SAS home directory.

 

Iam using below code in ASP.NET application to read .xpt files and convert to SAS dataset.

 

 

 

 

using SAS.UV.Transport;

 

 

SAS.UV.Transport.TransportFile tf = new SAS.UV.Transport.TransportFile(@"D:\tildra-pss\adlb.xpt");

var x = tf.Datasets;

 

 

 

 

 

Please find the attached screenshots for the errors raised.

 

 

Thanks

Attachment
Community Manager
Posts: 3,188

Re: Problem with SAS.UV.Transport dll

I'm afraid we can't help you with this.  We do not support any APIs related to using components of the SAS Universal Viewer in this way.

 

You might be able to accomplish what you need directly with the SAS OLE DB Local Data Provider.  See the "cookbook" documentation and search for XPT.

 

And I have some examples in this OLE DB blog series.

Frequent Contributor
Posts: 136

Re: Problem with SAS.UV.Transport dll

The code appears to be from a blog post of mine in 2011. I have just updated it showing you how to fix the issue:

 

http://savian.blogspot.com/2011/02/sas-transport-files-and-net.html

 

Community Manager
Posts: 3,188

Re: Problem with SAS.UV.Transport dll

Thanks @AlanC .  Of course, SAS still doesn't officially support that use of piecemeal DLLs from a packaged product.  But, as my daughters like to say, you do you. Smiley Wink

Frequent Contributor
Posts: 136

Re: Problem with SAS.UV.Transport dll

Posted in reply to ChrisHemedinger
Yeah, I know 😉

I took the time to figure it all out in binary but it was a very long week to get the floats figured out (it also got coded years after I put that blog post up).

I may release the binary code at some point but not w/o thinking about it a bit.


Ask a Question
Discussion stats
  • 4 replies
  • 121 views
  • 0 likes
  • 3 in conversation