Not able to Paste the code in the Editor Window

Reply
Frequent Contributor
Posts: 75

Not able to Paste the code in the Editor Window

Hi,

I am not able to paste any code/content/text in the forum's Editor Window even if I change to Advanced Editor window the paste doesn't work.

I always pasting it in a textpad and attaching it. It would be nice if I have some option to paste the tested code in the Editor Window.

Thanks

Dhanasekaran R

SAS Super FREQ
Posts: 3,476

Not able to Paste the code in the Editor Window

I also have this problem.

Rick

SAS Super FREQ
Posts: 3,476

Re: Not able to Paste the code in the Editor Window

Still have the same problem. If you ever want to investigate on a machine here at SAS. Give me a call.  It is truly a pain to not be able to paste directly from the SAS Enhanced Editor into the Forum.

PROC Star
Posts: 7,363

Re: Not able to Paste the code in the Editor Window

Rick,  This doesn't address the issue you raised here but it may provide the answer to the question you asked Chang yesterday in a different thread.  Later in this thread datanull points out that he has gotten around the issue by pasting to MS Word and then copying and pasting from there back to the Forum.  Using that method, he has been able to retain the format and highlighting.

SAS Super FREQ
Posts: 3,476

Re: Not able to Paste the code in the Editor Window

Yes, that does work, thanks. I can also paste from other sources. However, I can't paste directly from the SAS Enhanced Editor or from the EG program editor.  Until I can, I'll keep ringing the gong and reminding the administrators that this is an unsatisfactory situation that needs to be resolved.

Respected Advisor
Posts: 3,777

Not able to Paste the code in the Editor Window

I have to paste to MS Word then copy again and paste to forum.  This new forum doesn't know SAS; :-)

Trusted Advisor
Posts: 2,113

Re: Not able to Paste the code in the Editor Window

I have no problem pasting from any source that I use (with CTRL+V).  I wonder if it is browser/OS related.  (I'm using FireFox 4.0 on Windows XP). 

What browsers/OS you are working with?

(I tried NotePad, EMACS (PC), and a web address.  I don't have textpad.  I did find that sometimes a right-click showed a paste option and other times it tried to insert a picture.)

Frequent Contributor
Posts: 100

Not able to Paste the code in the Editor Window

I am unable to paste as well with Win XP, IE8 -  Come on, really?

Respected Advisor
Posts: 3,777

Re: Not able to Paste the code in the Editor Window

To carry that request a bit further I would like to see SAS as a language on the INSERT-Syntax Highlighting menu.

This forum don't know SAS. :smileyconfused:

PROC Star
Posts: 7,363

Re: Not able to Paste the code in the Editor Window

DataNull,  While I know that I don't recall ever seeing any Friday (or Thursday) humor on the forum, I can't resist.  As I point out in the next to last slide in the following presentation, SAS don't know SAS:

http://www.sas.com/offices/NA/canada/downloads/presentations/TASS-0311/SAS-Tips.pdf

Occasional Contributor
Posts: 10

Not able to Paste the code in the Editor Window

I'm also having the same issue (using IE6, and no, upgrading to a modern browser isn't an option) , it's really frustrating not to be able to paste into these editor windows.

Super User
Posts: 17,806

Not able to Paste the code in the Editor Window

Hmm...it does paste fine into firefox but not into IE7 Smiley Sad

PROC Star
Posts: 7,363

Not able to Paste the code in the Editor Window

It also pastes fine with Google Chrome, but that doesn't help those who have to be on whatever version of IE their company requires.

SAS Employee
Posts: 224

Not able to Paste the code in the Editor Window

This problem does appear to be browser-specific and not as much user-specific. We're looking into fixes and or setting recommendations that we can make to improve this process.

Keep posting your experiences. They help track the issues.

SAS Employee
Posts: 224

Re: Not able to Paste the code in the Editor Window

We have been testing this on different machines and in different browsers.  This functionality seems to be dependent on the settings of the client (browser).  I am currently creating this comment in IE 8.   I can copy and paste text into the space using the control key combinations but only after I have switched to the advanced editory.  Even then, IE presents me with a browser message requiring me to Allow access from the clipboard.  Once I do that, I can copy and paste text.

I cannot copy and paste an image in IE.  I can however, copy and paste an image using Firefox.  Given these findings, I don't believe that there is anything that I can modify in the system that will change this behavior.

Again,

Keep posting your experiences. They help track the issues.  [text copied and pasted from above]

Updated:

If you are using IE and can control your browser settings.  Try this.

In your browser, go to Tools --> Internet Options and look for these settings:

settings.gif

Set to either Enable or Prompt.

Ask a Question
Discussion stats
  • 24 replies
  • 2145 views
  • 5 likes
  • 14 in conversation