Manual assignment of multiple libnames with proc ds2

Reply
Contributor
Posts: 24

Manual assignment of multiple libnames with proc ds2

Hello, Community.

When I run proc ds2 in our SAS environment (which runs SAS 9.4), I get an error due to some Oracle schema being locked:

6    rsubmit;

NOTE: Remote submit to SASHOST commencing.

37   proc ds2;

ERROR: General error ORA-28000: the account is locked

ERROR: TKTS initialization failed.

38   data _null_;

39     declare int a;

40     method run();

41       a=1;

42        put a=;

43     end;

44    enddata;

45   run;quit;

NOTE: The SAS System stopped processing this step because of errors.

NOTE: PROCEDURE DS2 used (Total process time):

      real time           2.60 seconds

      cpu time            0.65 seconds

NOTE: Remote submit to SASHOST complete.

I circumvent this problem by using the nolibs statement, so that proc ds2 won't connect to any libnames automatically, and by specifying which libnames I want a connection to:

proc ds2 nolibs conn="DRIVER=base;CATALOG=WORK;SCHEMA=(NAME=WORK;PRIMARYPATH={%sysfunc(pathname(work))})";

data _null_;

     declare int a;
          method run();
            a=
1;
           
put a=;

          end;

enddata;

run;quit;

However, I want to connect to more than one libname in my proc ds2, but I can't find the syntax for doing this. For instance, I want the following to run:

proc ds2 nolibs /*some connection statements*/;

data work.class(overwrite=yes);

declare int a;
method run();         
set {select * from sashelp.class};
   
a=
1;
end;

enddata;

run;quit;

But at the moment, I can only establish one connection, to either work or sashelp, using the "conn" statement from above. What is the syntax for establishing two connections?

Best regards,

Rasmus Hedegaard.

New Contributor
Posts: 2

Re: Manual assignment of multiple libnames with proc ds2

Hi Hedegaard,

 

It's been a while since you posted this so you may have found a solution already, however it is now possible to specify libnames in proc ds2 using the libs= option

 

See hotfix details here: http://support.sas.com/kb/56/410.html

 

Hope this helps

 

Richard

Ask a Question
Discussion stats
  • 1 reply
  • 430 views
  • 0 likes
  • 2 in conversation